Showing results for 
Search instead for 
Did you mean: 

Error trying install Intel System Studio


I have problems on install Intel System Studio Ultimate Edition 2017 Update 3 on my machine (Online and Offline).

The setup just closes after reading config.xml or license.js. No messages, no errors, it just closes...

The same problem occurs with Integrated Perfomance Primitives 2017 Update 3, both (System Studio and IPP) install worked perfect with Update 2.

I tried in two PCs - Windows 8.1 Embedded Industry and Windows 10, both have Visual Studio 2017. 

After replace .cat files and vs_processing.js in config/Base for same from Update 2, the setup installs normally, but not work in Visual Studio 2017.

The last log:

[t1b4c 2017.06.28 16:04:30.902 00001eab] [context]: INFO: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv.exe
[t1b4c 2017.06.28 16:04:30.902 00001eac] [context]: INFO: __________________________________
[t1b4c 2017.06.28 16:04:30.902 00001ead] [context]: INFO:                     ID: 77e49d34
[t1b4c 2017.06.28 16:04:30.902 00001eae] [context]: INFO:                  State: Complete
[t1b4c 2017.06.28 16:04:30.902 00001eaf] [context]: INFO:            InstallDate: 2017-03-23T12:18:23Z
[t1b4c 2017.06.28 16:04:30.902 00001eb0] [context]: INFO:       InstallationName: VisualStudio/15.2.0+26430.12
[t1b4c 2017.06.28 16:04:30.902 00001eb1] [context]: INFO:    InstallationVersion: 15.0.26430.12
[t1b4c 2017.06.28 16:04:30.902 00001eb2] [context]: INFO:       InstallationPath: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community
[t1b4c 2017.06.28 16:04:30.902 00001eb3] [context]: INFO:            Description: Free, fully-featured IDE for students, open-source and individual developers
[t1b4c 2017.06.28 16:04:30.902 00001eb4] [context]: INFO:            DisplayName: Visual Studio Community 2017
[t1b4c 2017.06.28 16:04:30.902 00001eb5] [context]: INFO:                Product: Microsoft.VisualStudio.Product.Community
[t1b4c 2017.06.28 16:04:30.902 00001eb6] [context]: INFO:            ProductPath: Common7\IDE\devenv.exe
[t1b4c 2017.06.28 16:04:30.903 00001eb7] [context]: INFO:           IsLaunchable: true
[t1b4c 2017.06.28 16:04:30.903 00001eb8] [context]: INFO:             IsComplete: true
[t1b4c 2017.06.28 16:04:30.903 00001eb9] [context]: INFO: __________________________________
[t1b4c 2017.06.28 16:04:30.905 00001eba] [context]: ERROR: Scripting error: 
[t1b4c 2017.06.28 16:04:30.905 00001ebb] [context]: ERROR: Uncaught SyntaxError: Unexpected token b
[t1b4c 2017.06.28 16:04:30.905 00001ebc] [context]: ERROR: 
[t1b4c 2017.06.28 16:04:30.905 00001ebd] [context]: ERROR: Line: 1: osoft.VisualStudio.Blend", "version":"15.0.26606.0", "type":"Vsix", branch:"pr
[t1b4c 2017.06.28 16:04:30.905 00001ebe] [context]: ERROR: 
[t1b4c 2017.06.28 16:04:30.905 00001ebf] [context]: ERROR: Scripting error: 
[t1b4c 2017.06.28 16:04:30.905 00001ec0] [context]: ERROR: Uncaught TypeError: Cannot call method 'GetVSInfo' of null
[t1b4c 2017.06.28 16:04:30.905 00001ec1] [context]: ERROR: C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Scenario\base.js
[t1b4c 2017.06.28 16:04:30.905 00001ec2] [context]: ERROR: Line: 38:     var ns_vs = base("vs_processing.js").GetVSInfo();
[t1b4c 2017.06.28 16:04:30.905 00001ec3] [context]: ERROR: 
[t1b4c 2017.06.28 16:04:30.906 00001ec4] [bind_script]: INFO: execute_script: C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Scenario\activation_actions.js
[t1b4c 2017.06.28 16:04:30.910 00001ec5] [context]: INFO: context_imp::execute_script: origin:C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Scenario\activation_actions.js
[t1b4c 2017.06.28 16:04:30.913 00001ec6] [bind_script]: INFO: execute_script: C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Base\license.js
[t1b4c 2017.06.28 16:04:30.918 00001ec7] [context]: INFO: context_imp::execute_script: origin:C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Base\license.js
[t1b4c 2017.06.28 16:04:30.922 00001ec8] [context]: INFO: Scenario::activation: actions generation started
[t1b4c 2017.06.28 16:04:30.923 00001ec9] [bind_script]: ERROR: Scripting error: 
[t1b4c 2017.06.28 16:04:30.923 00001eca] [bind_script]: ERROR: Uncaught TypeError: Cannot call method 'Add' of undefined
[t1b4c 2017.06.28 16:04:30.923 00001ecb] [bind_script]: ERROR: C:\Users\Flavio\Downloads\Intel\w_ipp_2017.3.210\config\Scenario\activation_actions.js
[t1b4c 2017.06.28 16:04:30.923 00001ecc] [bind_script]: ERROR: Line: 249:         ns.ConfigureByFlexlmFeatures.Add(ns.FilterComponentsByAvailableLicense
[t1b4c 2017.06.28 16:04:30.923 00001ecd] [bind_script]: ERROR: 
[t1b4c 2017.06.28 16:04:30.923 00001ece] [context]: ERROR: Exception handled calling mediaconfig.Go
[t1b4c 2017.06.28 16:04:30.923 00001ecf] [context]: INFO: MICL script execution complete. Thank you.
[t2448 2017.06.28 16:04:31.200 00001ed0] [ISSA]: ERROR: issa_uninit_flex: library is not initialized
[t2448 2017.06.28 16:04:31.200 00001ed1] [issa host]: INFO: issa_uninit_flex is called


0 Kudos
1 Reply

Hi Flavio,


there had been a bug found in Intel System Studio 2017 installation with Visual Studio 2017.

Could you try installing Intel System Studio 2018 beta instead? The fix has been included in this version.

Please go here and click 'Register&Download' :

Feel free to contact me if you encounter any further problems.


Thank you