Intel® System Studio
Ask questions and share information with other users of the Intel® System Studio.
Announcements
Intel® System Studio components are now transitioned to several Intel® oneAPI toolkits and can be found under Intel oneAPI Base Toolkit and Intel oneAPI IoT Toolkit. Use the respective forums for questions related to these components. Getting Started questions can be asked in the Registration, Download, Licensing and Installation forum. If you have Priority Support you can submit your question in the Online Service Center.

Local Variables Problem

USUG__Ugur
Beginner
382 Views

We are working on a bare metal project with Intel System Studio.  However, we can't see local variables when we are debugging with Intel System Debugger. We see "E-L-C-EVFAIL: Evaluation failed" message in Console View and nothing in Locals windows. (We are using GCC 4.9 with cygwin on Windows with out any optimization.) Do you know how can we see local variables while debugging a function?

0 Kudos
2 Replies
Soflen_S_Intel
Employee
382 Views

Hi,

Would you please submit a ticket to Online Service Center because we need more information about this issue.

Please share us with the information such as what platform, ISS version (NDA or Update3), how you reproduce the issue (a video clips would be better).

Thank you very much.

Best regards,

Soflen

Donald_H_
Beginner
382 Views

I have same problem here.

Recently I upgraded the software. Somehow it cannot evaluate variables in (UEFI) PEI stage any more, but it works fine in (UEFI) DXE stage. Do you know why? What kind of parameter did I miss?

 

Reply