Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Russell_B_1
Beginner
101 Views

Slow Clock 22.5Mhz instead of 32MHz

I am using the quark SE C1000 processor Before updating the boot ROM the board was running at 32MHz from the Crystal. When I look at OSC0_CFG1 at location B0800008 I get a value of 0x00070009. This states it is running the Crystal Osc with 5.5pf caps.

After I update the boot rom using studio my board speed drops to 22.5MHz because I am no longer running the Crystal but but running the Silicon osc. the value at OSC0_CFG1 = 0x00040002.  This stated the crystal trim has been switched from 5.5pf to 15.03pf and the Crystal osc is not enabled and we are running from the Silicon osc.

How do I configure studio to run from the crystal so I can get 32MHz?

0 Kudos
1 Reply
Russell_B_1
Beginner
101 Views

While trying to switch from the Silicon Oscillator to the Crystal Oscillator I bricked my  board.

I tried to changed location 0xB0800008 from 0x00040002 to 0x00000009. After that I could no longer flash or run programs. I tried to use article https://wiki.zephyrproject.org/view/Arduino_101#Flashing_using_JTAG_Adapter

To reload the  boot flash but received the error that is attached photo file. I was able to use this article to restore the BOOT FLASH on a different board that was not Bricked.

Does anyone know of a way to recover? I have a Flyswatter2  JTAG adapter.   

Reply