Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
19 Views

Vtunes data cannot be displayed: there is no viewpoint

Hi,

I running vtunes on SKY-H 4+4e platform on Ubuntu14.04 to profile the caffe framework. When I run the app for 100 test images it works perfectly but when I increase it to 500 images, it displays the message " The data cannot be displayed: there is no viewpoint applicable for data" for Memory Access profile and Advanced hotspot too. It works for Basic Hotspots.

In the Collection log:

Finalization completed successfully

Results is ready for analysis.

Cannot load data file '<path_to_data_file>"TBRW_doind(tbrwFile->gethandle(),streamIndex)"failed:invalid string(97))

Thanks,

Siddhesh

 

 

0 Kudos
4 Replies
Highlighted
19 Views

Hi Siddesh,

Vtune has a default file size collection of 500 MB . Looks like your file size might be an issue when your collecting data for 500 image. Try increasing the file size on the analysis target tab in Analyzer.

 

0 Kudos
Highlighted
19 Views

Hi Pallavi,

Thanks for your reply. I tried to increase the collection size to 10500 but the problem still persists. I am getting the same error message as before.

-Siddhesh

0 Kudos
Highlighted
19 Views

Hi Siddhesh,

                    Can you disable the ptrace_scope in Ubuntu and please check if it works then?

You can set the ptrace_scope value to "0", if it was set to "1".

echo 0 | tee /proc/sys/kernel/yama/ptrace_scope

You can verify if its set to "0" now :- "cat /proc/sys/kernel/yama/ptrace_scope".

Note:- You need sudo permission to set the ptrace_scope

If the above setting didn't help you, can you also try to disable "nmi_watchdog" just for profiling and then enable it back once done with profiling :-

Disable watchdog : -

echo 0 | tee /proc/sys/kernel/nmi_watchdog

Please do let us know if this solves the issue.

Regards,
Sukruth HV

                  

 

0 Kudos
Highlighted
19 Views

Hi Sukruth,

The ptrace_scope and nmi_watchdog were disabled before running the profiling tool, as mentioned in the installing instruction manual(prerequisite). Also on rebooting the system, I disable them each time. I am not sure if I am missing something else here.

Thanks,

Siddhesh

0 Kudos