Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mauricio_c_1
Beginner
136 Views

problem building on the D2000

Jump to solution

good day

im folling the steps in showed in the "Intel® Quark™ Microcontroller Getting Started on Windows*: Video" but when i build the project hello world i get the following:

14:38:12 **** Build of configuration build_debug for project test ****
make 
APP_NAME = test
SOC = quark_d2000
APP_DIR = .
BUILD = debug
make -C ./bsp/drivers SOC=quark_d2000
BUILD = debug
make[1]: Entering directory `C:/IntelSWTools/ISSM_2016.0.027/workspace/test/bsp/drivers'
      0 [main] sh 4748 sync_with_child: child 2088(0x17C) died before initialization with status code 0xC0000142
     21 [main] sh 4748 sync_with_child: *** child state waiting for longjmp
/usr/bin/sh: fork: Resource temporarily unavailable
make[1]: *** [../drivers/debug/quark_d2000/obj/qm_adc.o] Error 128
make[1]: Leaving directory `C:/IntelSWTools/ISSM_2016.0.027/workspace/test/bsp/drivers'
make: *** [libqmsi] Error 2

14:38:14 Build Finished (took 1s.907ms)

i tried with others templates and get the same. Im working on windows 8.

how can i fix it

0 Kudos
1 Solution
Richard_A_Intel
Employee
136 Views

Mauricio,

There are a number of applications that can cause this issue,  most commonly I have seen it occur with MinGW, Cygwin, or any bash utilities you may have installed on windows.  An easy workaround to make sure you get them all is to edit the launcher file "issm_env.bat" in your install directory and add this line: set PATH= as shown below:

::
:: Extend PATH with ISSM tools
::
set PATH= 

set PATH=%ISSM_UTILS_ROOT%;%ISSM_TOOLCHAIN_BIN%/;%ISSM_TOOLCHAIN_UTILS%;%ISSM_TOOLS_ROOT%/python;%PATH% 

View solution in original post

8 Replies
Richard_A_Intel
Employee
136 Views

Mauricio,

Thank you for your question, this is a bug in our software caused by a conflict with 3rd party make utils.  We are looking into a fix at this time.  To get you tools working until then I recommend temporarily removing any 3rd party make tools from your path and then running Intel(R) System Studio for Microcontrollers again.

Thank you,
Richard

mauricio_c_1
Beginner
136 Views

hi richard 

thanks for your answer, sorry about my ignorance, but witch path and what kind of 3rd party make tools i should remove

thank you

Mauricio 

Richard_A_Intel
Employee
137 Views

Mauricio,

There are a number of applications that can cause this issue,  most commonly I have seen it occur with MinGW, Cygwin, or any bash utilities you may have installed on windows.  An easy workaround to make sure you get them all is to edit the launcher file "issm_env.bat" in your install directory and add this line: set PATH= as shown below:

::
:: Extend PATH with ISSM tools
::
set PATH= 

set PATH=%ISSM_UTILS_ROOT%;%ISSM_TOOLCHAIN_BIN%/;%ISSM_TOOLCHAIN_UTILS%;%ISSM_TOOLS_ROOT%/python;%PATH% 

View solution in original post

mauricio_c_1
Beginner
136 Views

hi richard

i edited the issm_env.bat with the lines you give me and i get the same result.

is there an other way to work around, i havent worked with MinGW, or Cygwin, or anything like that

 

thanks

Mauricio

Richard_A_Intel
Employee
136 Views

Mauricio,

Can you try with the latest version of the tools and see if the problem persists?  I just noticed you are using an older one and we have improved our Getting Started Guide based on feedback we received from customers.  You can find the link here: https://software.intel.com/en-us/iot/hardware/d2000/get-started

Thank you,

Richard

mauricio_c_1
Beginner
136 Views

hi Richard

i downloaded the new version and follow the guide, at the moment of build the hello_world project i get an issue similar to the first, this is what i get on the console

11:03:43 **** Build of configuration Debug for project Hello_World ****
make 
APP_NAME = Hello_World
SOC = quark_d2000
TARGET = x86
APP_DIR = .
BUILD = debug
CSTD = c99
VERSION = '1.1.0'
make -C ./bsp/drivers SOC=quark_d2000 TARGET=x86 BUILD=debug V=0 CSTD=c99
BUILD = debug
CSTD = c99
VERSION = '1.1.0'
make[1]: Entering directory `C:/IntelSWTools/ISSM_2016.1.067/workspace/Hello_World/bsp/drivers'
      0 [main] sh 10988 sync_with_child: child 11008(0x188) died before initialization with status code 0xC0000142
     22 [main] sh 10988 sync_with_child: *** child state waiting for longjmp
/usr/bin/sh: fork: Resource temporarily unavailable
make[1]: *** [../drivers/debug/quark_d2000/x86/obj/clk.o] Error 128
make[1]: Leaving directory `C:/IntelSWTools/ISSM_2016.1.067/workspace/Hello_World/bsp/drivers'
make: *** [libqmsi] Error 2

11:04:06 Build Finished (took 23s.184ms)

 

it looks similar but is a diferent error, how i should proceed?

thanks

Mauricio

Richard_A_Intel
Employee
136 Views

Mauricio,

Did you apply the edit to the issm_env.bat for the new build?  Just a note, you will also need to close and reopen the application after making the change.

Thank you,

Richard

 

mauricio_c_1
Beginner
136 Views

hi richard

thanks i forget about that, after editing and running as admin it build normally

thanks

Mauricio 

Reply