Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Fernando_H_Intel
Employee
189 Views

socwatch in CentOS 7.4 requiring GLIBC 2.18 in CentOS 7.4

Socwatch release notes says GLIBC 2.17 is a requirement , which seems fine since CentOS 7.4 comes with this version, but when socwatch is run it seems to request GLIBC 2.18.

I have I tried difference options including updating to CentOS 7.6. I am trying to get libstdc++.so.6 compiled with GLIBC 2.7, but I am not having  luck with this.

Error:

/socwatch: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /opt/intel/system_studio_2019/energy_profiler_and_socwatch/socwatch_for_target/socwatch_linux_v2.9.0_x86_64/libs/sys_libs/libstdc++.so.6)

On Ubuntu 16.04 works fine, which comes with GLIBC 2.23.

It seems to be an issue with the libstdc++.so.6 provided with socwatch v2.9.0. I tried v2.6.1 getting the same issue. I run CentOS with no GUI (minimal install)

 

0 Kudos
0 Replies
Reply