Intel Unite® App
Gain crucial understandings of the Intel Unite® App
Announcements
This product has been discontinued. This board is currently read only and no longer accepting new posts. Learn more
459 Discussions

Certificate Error - Don't have SHA-2 certificate

KGilp
Novice
1,499 Views

Hi,

I have run Unite Hub in debug and see the 'Blocking Insecure Certificate: SHA1_RSA... 'Could not establish trust relationship for the SSL/TLS secure channel with authority...'

I found the above in community and it would be great if I could skip the certificate check but my issue is I do not have this registry key on my hub. Unite is indeed installed but I don't even have the Unite sub under key Intel. Any ideas or help?

Thanks.

0 Kudos
3 Replies
idata
Employee
441 Views

Hello kargy,

Thank you for bringing this to the Intel® Unite™ app community.

Please let me review this matter, I will update the thread as soon as possible.

Regards,

Amy C.

0 Kudos
idata
Employee
441 Views

kargy, could you please enter a couple of registry keys manually? Please see below;

Registry Keys: (machine)

HKEY_LOCAL_MACHINE\software\Intel\Unite\ DisableCheckCertificateChain (DWORD) [Set for SelfSigned Certificates, where if 1 = do not check certificate chain of Enterprise (Server Certificate)

HKEY_LOCAL_MACHINE\software\Intel\Unite\AllowInsecureCertificates (DWORD) [1 = certificate algorithm check should be skipped 0 = the enterprise certificate is forced to use a SHA2 certificate] Both

Regards,

Amy C.

0 Kudos
idata
Employee
441 Views

kargy,

If you need further assistance let us know.

Regards,

Amy C.

0 Kudos
Reply