Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SCort2
Beginner
473 Views

Unknown server response at RequestPinFromRanger, server return: 500

Server version: 4.1.413.43

Hub version: 4.1.413.43

Hub manufacturer/model: HP Elitedesk 800 G3/G4 and Intel NUC NUC7i5DNKE

Hub OS: Windows 10 x64 v1903

 

On every PIN renewal, our Intel Unite Hubs take a long time to receive the new PIN. After approximately 10-15 seconds then the PIN is received.

 

The logs on the server show the following:

  • Device Name: All Unite Hubs
  • Source: HubTcpRangerConnectionModule
  • Message: Unknown server response at RequestPinFromRanger, server return: 500

 

The IntelUniteServerLog.txt constantly grows and contains the following error message over and over:

 

Can you please help?

 

Thanks,

Silvio

 

0 Kudos
10 Replies
AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

Thank you for posting on the Intel® communities.

In order to understand better your environment, could you please provide or confirm the following details?

 

A- Is this a new deployment of the Intel Unite® app? Did it work fine before without this issue with the same and/or different versions of the software?

 

B- Environment details:

1- Environment for this deployment of Intel Unite® app: (office, enterprise, school, hospital, factory, home):  

 

2- HUB SKUs number for HP Elitedesk 800 G3/G4. If running windows, this can be checked on Windows® >> System Information by running the command "msinfo32" from the Windows® Run box.

 

3- Client model(s):  

4- Windows OS (provide Version number if Win10, and 32- or 64-bit) and update version:

 

5- HUB and Client Graphics Driver version and vendor:

 

6- Number of systems affected (for instance: 4 HUBs, 20 clients, etc):

 

C- Additional logs from the Server and Hub:

1- For the Server, we noticed you provided details regarding the IntelUniteServerLog.txt log file, could you please also provide the IntelUniteTransactionLog.txt and UniteServerLog.txt?

 

2- Please provide the HUB log, which is created by default and is called Unite.sql. This file is located on C:\Users\User\AppData\Local\Temp. This file is an SQLite database, and it can be opened with any SQL Client.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

SCort2
Beginner
180 Views

Hi Andrew,

 

Thanks for the reply. Here are the answers.

 

A. We were running Intel Unite version 3.3 and then upgraded to version 4.0.4173.30. Recently I upgraded to 4.1.371 and shortly after to the latest 4.1.413.43. As far as I can tell the issue started after the upgrade to version 4.1.

 

B.1 This is an enterprise environment.

B.2 SKU - 4KW12ET#ABU

B.3 Clients are running either HP Elitebook 800 laptops or Apple MBP. The issue is happening on HUBs only.

B.4 All HUBs and Windows client are running the same version of Windows (Windows 10 Pro, version 1903. OS build 18362.356). All are 64 bit versions.

B.5 What does the graphic driver version have to do with this issue? The HUB is unable to get the renewed PIN, irrespective of graphic card.

B.6 All HUBs are effected. We have about 50 of them.

 

C.1 Please provide an e-mail address where I can send the files.

C.2 This is an extract from the HUB log showing the error. Please provide an e-mail address and I'll provide all 3 log files

  • 6 HubTcpRangerConnectionModule At RequestPinFromRanger, hub ipAddresses: ***.***.***.*** 2019-12-11 10:43:20 1 413d3aad-a93d-47fc-9fe6-d2593c6b8e78
  • 4 RangerHelper AT RequestPin: {"code":500,"success":false,"data":{"message":"An internal error has ocurred"}} 2019-12-11 10:43:21 1 413d3aad-a93d-47fc-9fe6-d2593c6b8e78
  • 2 HubTcpRangerConnectionModule Unknown server response at RequestPinFromRanger, server return: 500 2019-12-11 10:43:21 1 413d3aad-a93d-47fc-9fe6-d2593c6b8e78

 

Regards,

 

Silvio

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

Thank you for all the information provided.

 

I would like to inform you that I will send you an email so you can reply back and provide us with all 3 logs files so we can assist you better.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

We have received the logs files and we are currently working with all the information you provided.

Also, could you please confirm if the upgrades from Intel Unite® version 3.3 to 4.0.x, and finally to 4.1.371 were performed from scratch? (clean installation?)

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

SCort2
Beginner
180 Views

Hi Andrew,

 

The upgrade to version 4.0 was a clean installation although both versions were running on the same server. All others were in place upgrade.

 

Regards,

 

Silvio

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

Thank you for the details provided.

 

We are checking all the information and reports and as soon as we have more details regarding the issue described we will be posting back in this thread.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

We are still investigating the behavior described with the delay on the HUBs to renew the PIN.

 

To check further this, could you please provide the following details?

 

1- Have you confirmed the HUBs and clients have been properly provisioned by following the instructions on the Intel Unite® app version 4.x Deployment Guide? For instance, sections 5.6.2.1 and 7.3.1.6.

 

2- Since the issue started after updating to version 4.1, besides updating the software on the Server, HUB, and clients, were the cab files also uploaded and updated in the Admin Web Portal?

 

3- Have you checked if there could be some rules or settings on Firewalls or other security network devices that may be affecting the connectivity or communication with the Server?

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

SCort2
Beginner
180 Views

Hi Andrew,

 

The issue was causing a lot of issues (log files on the Unite server growing uncontrollably, HUBs getting PIN codes after minutes), so I've decided to perform a clean installation (new SQL database). All issues have been resolved with the clean installation. Note that same server was used, same installation/manifest files.

 

With regards to your questions,

  1. Yes, all HUBs were correctly provisioned. No changes were done recently on the HUB computers.
  2. All CAB files are updated with every upgrade.
  3. No firewall rules are blocking the connection. As you can see in the log the HTTPS connection is arriving on the server and its giving an internal server error (error 500).

 

The issue must be within the database and it was caused during the upgrade from version 4.0 to 4.1.371. The only downside now is that the previous telemetry data is lost, but PIN renewal is immediate.

 

 

 

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

Thank you for your response.

I am glad to know that the clean installation resolved the issue with the PIN renewal.

 

Nevertheless, please allow us to look into the logs and the telemetry data inquiry and as soon as we have any updates, we will be posting back in this thread.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

AndrewG_Intel
Moderator
180 Views

Hello SCort2,

 

After checking further this behavior, this seems to be an isolated issue as you previously pointed out related to the database. Also, the telemetry data would be lost if a backup of the database is missing.

 

We are glad that you managed to resolve the issue and we appreciate the feedback regarding the steps you followed. We will proceed to close this inquiry.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

Reply