Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yesilgulalp
Novice
433 Views

Beginner the oneAPI

Jump to solution

Hi, I'm so new to parallelism and oneAPI. My knowledge level is so low about this subject. I find a book and its name is  "C++ Parallel Programming with Threading Building Blocks". I'm reading and take note of this book. I installed oneAPI Base Toolkit after installed visual studio 2019 also when I installing visual studio I selected C++ desktop environment. When I create empty project from the visual studio 2019 I can not the access oneAPI library. Although I follow the instructions in the book, I guess I can't do it but when I create oneAPI specific sample , the library is coming out, for example, when i create the oneDPL sample dpl library is coming out. I know it is so silly question but as i said I'm very newbie, i don't find a way. How can i access the all library when i create the empty project or how can add the header file i guess is about the IDE ?

Labels (1)
Tags (1)
0 Kudos
1 Solution
AbhishekD_Intel
Moderator
300 Views

Hi,


Sorry for the delay.

We are also facing the same issue while using oneDPL with Visual Studio.

As a workaround, please try using a command line to compile and execute oneDPL programs.

This issue is more likely from the VS environment.

We are forwarding this issue to the concerned team.


Warm Regards,

Abhishek


View solution in original post

6 Replies
AbhishekD_Intel
Moderator
402 Views

Hi,


Thanks for reaching out to us.

To create a DPC++ project in Visual Studio 2019, please follow the following steps, you will get the complete environment to create your oneAPI project.

  1. Open VS and create a new project.
  2. Select DPC++ Console Application and not empty project.
  3. And follow the instructions.

After the above steps, you will get a sample code inside your project's source files section. You can update the .cpp file or can create a new one inside it.


For including the library support goto Project Properties -> Intel Libraries for oneAPI -> select that you want to use. This will include the support of the selected library in your project.


Hope the provided details will help you to solve your problem.


Warm Regards,

Abhishek



yesilgulalp
Novice
396 Views

Thank you so much for informations, but i try that actually i saw that options but still i can not access the DPC++ library i check the github page and i saw there parallel STL library inside the DPC++ library but i could not find it when i wrote the #include <dpc/pstl>  there isn't library like that  or #include<oneapi> there is only tbb library  and there is no options for dpc++ library in project properties.

but when i create a DPC++ sample for example, Browse Intel one API Samples -> oneAPI Libraries -> oneDPL, then the dpl library exist

and again sorry for the silly question 

Tags (1)
AbhishekD_Intel
Moderator
301 Views

Hi,


Sorry for the delay.

We are also facing the same issue while using oneDPL with Visual Studio.

As a workaround, please try using a command line to compile and execute oneDPL programs.

This issue is more likely from the VS environment.

We are forwarding this issue to the concerned team.


Warm Regards,

Abhishek


View solution in original post

yesilgulalp
Novice
280 Views

thank you so much have a good day 

Igor_V_Intel
Employee
276 Views

You need to set required VC++ directories to point to the location of header files. In sample you can find additional paths set in project properties by clicking Project -> gamma-correction properties -> VC++ Directories -> Include Directories. Required header files are located in C:\Program Files (x86)\Intel\oneAPI\dpl\latest\windows\include\. Please add this path in your new project.


AbhishekD_Intel
Moderator
74 Views

Hi,


Please try updating oneAPI toolkit to the latest version(2021.2).

This issue has been fixed in the latest oneAPI toolkit (2021.2). As this issue is resolved, we will no longer monitor this thread. If you require any additional assistance from Intel, please start a new thread. 

Any further interaction in this thread will be considered community only.



Warm Regards,

Abhishek



Reply