Intel® oneAPI Base Toolkit
Support for core tools and libraries to build and deploy high-performance data-centric applications
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
287 Discussions

Beta 08 windows installation fails prerequisite check

BLS3D
Beginner
544 Views

I'm not able to install the One API Base Toolkit on my laptop. I get the error Intel Graphics Driver for windows not found.
I believe I have the latest drivers for my intel graphics GPU (4600). My processor is the i7-4720HQ, is this compatible with the oneAPI toolkits Beta? If so, how can I install it?

0 Kudos
1 Solution
AbhishekD_Intel
Moderator
528 Views

Hi Richard,

Currently, Intel® OneAPI Base Toolkit supports GEN9 and higher GPUs. You can check your generation of iGPU from the below link.

https://software.intel.com/content/www/us/en/develop/articles/intel-graphics-developers-guides.html


It seems that you are not using GEN9 or higher GPU that's the reason for the error you are getting.

So if you want to use Intel OneAPI Base Toolkit please go through the system requirements check the link below.

https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-base-toolkit-system-requi...



Warm Regards,

Abhishek


View solution in original post

5 Replies
AbhishekD_Intel
Moderator
529 Views

Hi Richard,

Currently, Intel® OneAPI Base Toolkit supports GEN9 and higher GPUs. You can check your generation of iGPU from the below link.

https://software.intel.com/content/www/us/en/develop/articles/intel-graphics-developers-guides.html


It seems that you are not using GEN9 or higher GPU that's the reason for the error you are getting.

So if you want to use Intel OneAPI Base Toolkit please go through the system requirements check the link below.

https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-base-toolkit-system-requi...



Warm Regards,

Abhishek


BLS3D
Beginner
522 Views

@AbhishekD_Intel ,

Thank you for your reply.  The processor in my laptop is a gen 4 cpu, so it's not supported by oneAPI Toolkit.  Maybe you could display a disclaimer for people that opt to download and install the toolkit.  If there is a disclaimer that exists already , maybe intel can make it more obvious so that users don't waste time trying to install it on incompatible machines.

Thanks again,

Richard

 

AbhishekD_Intel
Moderator
514 Views

Hi @BLS3D ,

 

Thanks for the suggestions. Please refer the below link:

https://software.intel.com/content/www/us/en/develop/tools/oneapi/base-toolkit.html

 

So if you will see there is already Before You Begin tab which will redirect you to check whether your system meets the minimum requirements or not. Then the next step is to Download the Base Toolkit.

Please go through the above link for more details. Thank You!

 

 

Warm Regards,

Abhishek

 

AbhishekD_Intel
Moderator
488 Views

Hi,


Please, update us on the mentioned details. Hope those details have helped you in solving your issue.


Warm Regards,

Abhishek


AbhishekD_Intel
Moderator
476 Views

Hi,


As your issues are resolved we are not monitoring this thread. Please post a new thread if you have any issues.


Thank you

Abhishek


Reply