Intel® oneAPI Base Toolkit
Support for core tools and libraries to build and deploy high-performance data-centric applications
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
242 Discussions

Build and run a sample project: LLVM ERROR SPIRV internal error

alpha_lyra
Beginner
741 Views

After installing oneAPI Base Toolkit on Windows 10, I am trying to build and run a sample project described in the "Get Started with the Intel oneAPI Base Toolkit for Windows" document. I attempted building and running vector-add project in 2 methods described below which lead to an error on the command prompt: 

 

Running on device: Intel(R) HD Graphics 520
Vector size: 10000
LLVM ERROR: SPIRV internal error.
C:\Users\username\source\repos\Base_Vector_Add\x64\Debug\vector-add-usm.exe (process 6544) exited with code 1.
Press any key to close this window . . .

 

I cannot figure out how to fix this issue as I failed to find similar issues on the forum or other sources on the internet. I want to make sure that I installed oneAPI base toolkit properly, which does not seem to be the case. 

Method 1:
On Visual Studio 2019, I selected "Browse an Intel oneAPI Sample" and rebuilt vector-add-usm. I clicked "Start Without Debugging" and received the aforementioned error. 

Method 2:
I opened cmd.exe and ran setvars.bat. I ran openapi-cli.exe, created project, selected Vector Add sample, built using MSBuild, and ran vector-add-usm.exe (There was no vector-add.exe, but there was vector-add-buffer.exe for your information).  Then, I received the aforementioned error.

0 Kudos
1 Solution
AbhishekD_Intel
Moderator
723 Views

Hi,


Thanks for reaching out to us.

Please check if you have installed the latest graphics drivers, the recommended one is 27.20.100.9030.

Even after updating drivers, you are getting the same error then try running your samples with cpu_selector, and if you get errors then completely uninstall the base toolkit and reinstall it.


This should solve your issue. If you have any other issues do let us know.

We tried running the sample using the latest base toolkit and it's working for us.



Warm Regards,

Abhishek


View solution in original post

3 Replies
AbhishekD_Intel
Moderator
724 Views

Hi,


Thanks for reaching out to us.

Please check if you have installed the latest graphics drivers, the recommended one is 27.20.100.9030.

Even after updating drivers, you are getting the same error then try running your samples with cpu_selector, and if you get errors then completely uninstall the base toolkit and reinstall it.


This should solve your issue. If you have any other issues do let us know.

We tried running the sample using the latest base toolkit and it's working for us.



Warm Regards,

Abhishek


View solution in original post

alpha_lyra
Beginner
716 Views

Thank you so much! Updating to the latest graphic driver worked.

However, I had to "manually" update the driver following this procedure since I was getting errors when I attempted to update from the device manager. 

Nonetheless, the sample program ran properly. You saved my day!

AbhishekD_Intel
Moderator
701 Views

Hi,

 

Thanks for the confirmation.

Glad that your issue is resolved. Please post a new thread if you have any other issues.

Also, try using Intel Driver and Support Assistant for the latest details and installation of drivers.

We will no longer monitor this thread as this issue is resolved.

 

 

Warm Regards,

Abhishek

 

Reply