Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
160 Views

Can't install intel-oneapi-dpcpp-debugger-10.0-beta09 on Ubuntu 18.04

After running and trying to install updates via "Software updater" i receive the following error message:

"intel-oneapi-dpcpp-debugger-10.0-beta09: Depends: intel-oneapi-dpcpp-debugger-eclipse-cfg (>= 10.0-2083.beta09) but it is not installed"

Any thoughts on how to fix that? I tried "apt --fix-broken install" but that produced the same message.

Thanks in advance.

 

5 Replies
Highlighted
Moderator
118 Views

Hi,


Thank you for reaching out to us.

We are also getting the same issue while updating the Intel OneAPI basekit.

So we are forwarding this issue to the concerned team.

We will get back to you at earliest.



Warm Regards,

Abhishek


0 Kudos
Highlighted
Novice
88 Views

Thanks. The error occurred while updating from 2021.1 beta08.

Also, in my original post I should have included a little more information on my system:

OS:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

----

CPU: Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
GPU: VGA compatible controller: Intel Corporation Device 3ea9 (rev 01)
GPU driver: Installed as per instructions found here: https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-bionic.html
oneAPI: oneAPI Base Toolkit beta 2021.1 beta08, installed at the time of upgrade

 

 

0 Kudos
Highlighted
Novice
79 Views

Update:

This morning I followed the instructions on updating the "Intel Repository" public key. Then after running "sudo apt update" in terminal, the result of running "sudo apt --fix-broken install" is the following:

<name>@<name>-NUC8i5BEHS:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
intel-oneapi-ccl-2021.1-beta08 intel-oneapi-common-licensing-2021.1-beta08 intel-oneapi-compiler-shared-2021.1-beta08 intel-oneapi-compiler-shared-common-2021.1-beta08
intel-oneapi-compiler-shared-common-runtime-2021.1-beta08 intel-oneapi-compiler-shared-runtime-2021.1-beta08 intel-oneapi-daal-2021.1-beta08
intel-oneapi-daal-common-2021.1-beta08 intel-oneapi-daal-common-devel-2021.1-beta08 intel-oneapi-daal-devel-2021.1-beta08 intel-oneapi-dev-utilities-2021.1-beta08
intel-oneapi-dpcpp-compiler intel-oneapi-dpcpp-compiler-2021.1-beta08 intel-oneapi-dpcpp-ct-2021.1-beta08 intel-oneapi-dpcpp-debugger-10.0-beta08
intel-oneapi-icc-common-2021.1-beta08 intel-oneapi-icc-dpcpp-shared-2021.1-beta08 intel-oneapi-icc-runtime-2021.1-beta08 intel-oneapi-ipp-2021.1-beta07
intel-oneapi-ipp-common-2021.1-beta07 intel-oneapi-ipp-common-devel-2021.1-beta07 intel-oneapi-ipp-devel-2021.1-beta07 intel-oneapi-ippcp-2021.1-beta07
intel-oneapi-ippcp-common-2021.1-beta07 intel-oneapi-ippcp-common-devel-2021.1-beta07 intel-oneapi-ippcp-devel-2021.1-beta07 intel-oneapi-libdpstd-devel-2021.1-beta08
intel-oneapi-mkl-2021.1-beta08 intel-oneapi-mkl-common-2021.1-beta08 intel-oneapi-mkl-common-devel-2021.1-beta08 intel-oneapi-mkl-devel-2021.1-beta08
intel-oneapi-mpi-2021.1-beta08 intel-oneapi-mpi-devel-2021.1-beta08 intel-oneapi-onevpl-2021.1-beta08 intel-oneapi-onevpl-devel-2021.1-beta08
intel-oneapi-openmp-2021.1-beta08 intel-oneapi-tbb-2021.1-beta08 intel-oneapi-tbb-common-2021.1-beta08 intel-oneapi-tbb-common-devel-2021.1-beta08
intel-oneapi-tbb-devel-2021.1-beta08
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
intel-oneapi-dpcpp-debugger-eclipse-cfg
The following NEW packages will be installed:
intel-oneapi-dpcpp-debugger-eclipse-cfg
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
3 not fully installed or removed.
Need to get 0 B/1,928 B of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 249123 files and directories currently installed.)
Preparing to unpack .../intel-oneapi-dpcpp-debugger-eclipse-cfg_10.0-2083.beta09_all.deb ...
Unpacking intel-oneapi-dpcpp-debugger-eclipse-cfg (10.0-2083.beta09) ...
dpkg: error processing archive /var/cache/apt/archives/intel-oneapi-dpcpp-debugger-eclipse-cfg_10.0-2083.beta09_all.deb (--unpack):
trying to overwrite '/opt/intel/oneapi/etc/eclipse/gdb_oneapi.eclipse', which is also in package intel-oneapi-dpcpp-debugger-10.0-beta08 10.0-61.beta08
Errors were encountered while processing:
/var/cache/apt/archives/intel-oneapi-dpcpp-debugger-eclipse-cfg_10.0-2083.beta09_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now the problem is that a certain file cannot be overwritten. After first seeing this error message, I thought that a reboot might help, thinking that perhaps the package manager was in a bad state, but the results of doing so were the same.

Perhaps deleting the '/opt/intel/oneapi/etc/eclipse/gdb_oneapi.eclipse' would be a work-around?

Since I am no Linux-expert, I cannot be sure as to why I receive output different from that originally posted. Is it to do with update the public key, or has the repository that I am pulling packages from been updated? If it is the former, why is this not handled by "Software Updater" in the OS?

Cheers.

 

0 Kudos
Highlighted
47 Views

This issue has been escalated and is included in the Release notes for both Base and HPC toolkit as known issue.


0 Kudos
Highlighted
Novice
24 Views

Thanks for your reply @Subarnarek_G_Intel. And glad to hear that you guys are taking a look at this. In the mean time I am stuck with an installation of my OS that I can't seem to modify in any way, e.g. recently I tried install Visual Studio Code, which produced the same error message. To work around this I issued 'sudo apt --purge remove intel-basekit', but this also produces the original error. Short of re-installing my OS, do you have any thoughts on what I can do to uninstall the Base Toolkit?

Thanks in advance.

0 Kudos