Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Yen__Wayne
Beginner
275 Views

Cannot find /opt/intel/inteloneapi/setvars.sh

I follow below page to try Vector-Add Sample,but I cannot find /opt/Intel folder in my environment.

https://software.intel.com/en-us/articles/using-intel-devcloud-with-oneapi-products

 

I also reference OneAPI-codesample-beta02-RC2\DLDevKit-code-samples\DNNL_CNN_INFERENCE_FP32\README.md to build this sample,but I cannot find this file "setvars.sh" .

Please help.

 

 

Tags (1)
7 Replies
Viachek
Beginner
275 Views

Hi! In my point of view, when you are using DevCloud, you don't need to worry about setting environment variables - everything was already adjusted for users. As we are building and executing code on a remote node, setvars.sh already exists on it.

You can just follow that Guide step by step. Hope, everything will work!

WILLIAM_H_Intel4
Employee
275 Views

Wayne,

The issue with the setvars.sh is an issue currently under investigation by the team.  I cannot comment on a workaround or fix schedule at this time, but it will be fixed in an upcoming release.

William

Shubham_C_Intel
Employee
275 Views

Wayne,

Yes, This issue is there on some nodes on devcloud, in the meantime, this issue is being resolved,  please try it on some other nodes of devcloud.

Shubham

Nathan_G_Intel
Employee
275 Views

Wayne, Is this still a problem for you? 

If so , is it possible you were on a login node?

oneAPI is not installed on the login node of the DevCloud, only on the compute nodes.

Here is the Getting Started Guide

Also please provide more info:

  • what is the hostname of the machine where this issue happened?
  • what are the steps to reproduce?
  • etc, any relevant info
Shubham_C_Intel
Employee
275 Views

Wayne, This issue has been resolved on all NDA nodes. Can you check and confirm the status? Shubham
Light_Intel
Moderator
275 Views

Please confirm that your issue had been resolved. Thanks!

Dam__Chri
Beginner
275 Views

How best can that be with DevCloud, I don't really see how you can use DevCloud without setting environment variables.