Intel® oneAPI Base Toolkit
Support for the core tools and libraries within the base toolkit that are used to build and deploy high-performance data-centric applications.

Installation error

Helena1
Novice
1,167 Views

Hi, 

I am trying to install the oneAPI Base Toolkit, but am encountering the following error: 

03/01/2021 11:38:07:247 : 21196 : ERROR : Installation of component has failed.
Component id: intel.oneapi.win.cpp-compiler.ide.shared_vsix_llvm_vs2019, name: IDE C++ shared LLVM vsix for Visual Studio 2019, version: 2021.1.1-99.
Error: <CustomActionStep> Missing session identifier for deferred custom action

Does anyone know how to fix this? I'd appreciate any kind of help!
Thanks a lot!

0 Kudos
1 Solution
ArpanB_Intel
Moderator
1,053 Views

Helena, please check whether you are using the correct package of Microsoft Visual Studio 2019 from the link we had shared earlier with you.


Also, please note that prior to the installation of Microsoft Visual Studio, it is important that you choose the Desktop Development with C++ component. Please click here: https://software.intel.com/content/www/us/en/develop/articles/installing-microsoft-visual-studio-2019-for-use-with-intel-compilers.html, for further guidance.


View solution in original post

0 Kudos
1 Reply
ArpanB_Intel
Moderator
1,054 Views

Helena, please check whether you are using the correct package of Microsoft Visual Studio 2019 from the link we had shared earlier with you.


Also, please note that prior to the installation of Microsoft Visual Studio, it is important that you choose the Desktop Development with C++ component. Please click here: https://software.intel.com/content/www/us/en/develop/articles/installing-microsoft-visual-studio-2019-for-use-with-intel-compilers.html, for further guidance.


0 Kudos
Reply