Community
cancel
Showing results for 
Search instead for 
Did you mean: 
aaron2
New Contributor I
45 Views

gdb-oneapi LD_LIBRARY_PATH misconfigured

I have the oneapi with HPC packages installed, version 2021.1.1. From the oneapi directory I source the setvars.sh file to configure my environment. When I try to run gdb-oneapi I get the error message 

gdb-oneapi: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by gdb-oneapi)
gdb-oneapi: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/alm100/intel/oneapi/debugger/10.0.0/gdb/intel64/lib/libiga64.so)
gdb-oneapi: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/alm100/intel/oneapi/debugger/10.0.0/gdb/intel64/lib/libiga64.so)

My envrionment variable LD_LIBRARY_PATH is only set through the setvars.sh script, and looks like so:

/home/alm100/intel/oneapi/mpi/2021.1.1//libfabric/lib:/home/alm100/intel/oneapi/mpi/2021.1.1//lib/release:/home/alm100/intel/oneapi/mpi/2021.1.1//lib:/home/alm100/intel/oneapi/itac/2021.1.1/slib:/home/alm100/intel/oneapi/mkl/latest/lib/intel64:/home/alm100/intel/oneapi/compiler/2021.1.1/linux/lib:/home/alm100/intel/oneapi/compiler/2021.1.1/linux/lib/x64:/home/alm100/intel/oneapi/compiler/2021.1.1/linux/lib/emu:/home/alm100/intel/oneapi/compiler/2021.1.1/linux/compiler/lib/intel64_lin:/home/alm100/intel/oneapi/compiler/2021.1.1/linux/compiler/lib:/home/alm100/intel/oneapi/tbb/2021.1.1/env/../lib/intel64/gcc4.8:/home/alm100/intel/oneapi/debugger/10.0.0/dep/lib:/home/alm100/intel/oneapi/debugger/10.0.0/libipt/intel64/lib:/home/alm100/intel/oneapi/debugger/10.0.0/gdb/intel64/lib

I also tried sourcing the file debugger/latest/env/vars.sh in the oneapi directory, and it did not fix the issue. Doing a 

find . -name 'libstdc++*'

in the oneapi directory shows a few results, the most relevant being ./inspector/2021.1.1/lib64/libstdc++.so.6.0.22, which is newer than my system's version. If I modify my environment with

export LD_LIBRARY_PATH=$HOME/intel/oneapi/inspector/2021.1.1/lib64:$LD_LIBRARY_PATH

, then I am able to successfully run gdb-oneapi. Am I doing something wrong or is this a bug in the environment setting scripts?

0 Kudos
0 Replies