Intel® oneAPI Base Toolkit
Support for the core tools and libraries within the base toolkit that are used to build and deploy high-performance data-centric applications.
409 Discussions

oneapi-cli command can't connect through proxy

reynolds
Employee
1,126 Views

When running oneapi-cli list, I get the following response

~/data/oneAPI_samples$ oneapi-cli list
2022/09/01 12:33:17 failed to connect to sample aggregator for cpp samples, attempting to use local cache
2022/09/01 12:33:17 operating offline and local cache for cpp samples does not exist
Get "https://iotdk.intel.com/samples-iss/2022.2.0//cpp.json": context deadline exceeded (Client.Timeout exceeded while awaiting headers)
2022/09/01 12:33:27 failed to connect to sample aggregator for python samples, attempting to use local cache
2022/09/01 12:33:27 operating offline and local cache for python samples does not exist
Get "https://iotdk.intel.com/samples-iss/2022.2.0//python.json": context deadline exceeded (Client.Timeout exceeded while awaiting headers)
2022/09/01 12:33:37 failed to connect to sample aggregator for fortran samples, attempting to use local cache
2022/09/01 12:33:37 operating offline and local cache for fortran samples does not exist
Get "https://iotdk.intel.com/samples-iss/2022.2.0//fortran.json": context deadline exceeded (Client.Timeout exceeded while awaiting headers)
Failed to fetch sample index, this *may* be your network/proxy environment.
You might try setting http_proxy in your environment, for example:
Linux/Mac: export http_proxy=http://your.proxy:8080
Windows: set http_proxy=http://your.proxy:8080
no working sample languages configured [cpp python fortran]

 

But I am able to run the following fine: 

wget https://iotdk.intel.com/samples-iss/2022.2.0//cpp.json

 

I have setup wget to use proxy information to allow it to work.

I have tried configuring https_proxy variable in local enviornment, but makes no difference.

How can I configure oneapi-list command to also use proxy? 

 

Thanks

0 Kudos
1 Solution
reynolds
Employee
1,124 Views

Nevermind, my local proxy setting was incorrect. Please close this. Solved.

View solution in original post

0 Kudos
2 Replies
reynolds
Employee
1,125 Views

Nevermind, my local proxy setting was incorrect. Please close this. Solved.

0 Kudos
HemanthCH_Intel
Moderator
1,103 Views

Hi,


Glad to know that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks & Regards,

Hemanth


0 Kudos
Reply