Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Employee
119 Views

oneapi-cli "character set not supported"

:~$ source /opt/intel/oneapi/setvars.sh
:: initializing oneAPI environment ...
:: advisor -- latest
:: intelpython -- latest
:: vtune -- latest
:: tbb -- latest
:: dnnl -- latest
:: mkl -- latest
:: dev-utilities -- latest
:: dpcpp-ct -- latest
:: ipp -- latest
:: daal -- latest
:: mpi -- latest
:: ccl -- latest
:: ippcp -- latest
:: compiler -- latest
:: vpl -- latest
:: debugger -- latest
:: oneAPI environment initialized ::

~$ oneapi-cli
Connecting to online Sample Aggregator, this may take some time based on network conditions
2020/09/16 08:47:31 character set not supported

My system:

:~$ echo $LANG
en_GB.ISO-8859-15

:~$ oneapi-cli version
v0.0.15-28-gbedc4b7e51

:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

0 Kudos
9 Replies
Highlighted
Moderator
102 Views

Hi,

 

Can you give it a try by changing $LANG from ISO-8859-15 to UTF-8 ?

 

Also, if you are working behind a proxy, please set the value of http_proxy/https_proxy (Doesn't seem to be the case from the log)

 

 

export http_proxy=http://your.proxy:8080

 

 

Let me know how it goes.

 

 

Regards,

Rahul

0 Kudos
Highlighted
Employee
96 Views

Thanks for the quick response! Unfortunately, it won't fix the problem:

$ export LANG=UTF-8
$ echo $LANG
UTF-8
$ oneapi-cli
Connecting to online Sample Aggregator, this may take some time based on network conditions
2020/09/17 10:36:49 character set not supported

$ luit -encoding UTF-8 oneapi-cli
Connecting to online Sample Aggregator, this may take some time based on network conditions
2020/09/17 10:38:56 character set not supported

0 Kudos
Highlighted
Moderator
91 Views

Hi,

 

The default settings are stored in /etc/default/locale file.

 

Run:

 

cat /etc/default/locale

 

To view the default locale.

This file can be altered manually using any editor or update-locale tool.

 

update-locale LANG=en_GB.UTF-8

 

Try changing LANG value from en_GB.ISO-8859-15 to en_GB.UTF-8. Later, just restart the terminal and run oneapi-cli, to see if the updated setting makes any difference. (Make sure that you type all the hyphens and underscores)

 

Instead of changing the global setting, I would recommend you to run this command instead: (to have LANG setting just for this command)

 

LANG=en_GB.UTF-8 oneapi-cli

 

 

Let me know if it helps.

 

Regards,

Rahul

0 Kudos
Highlighted
Employee
81 Views

Sorry, still doesn't help:

$ sudo update-locale LANG=en_GB.UTF-8

.. new terminal..

$ source /opt/intel/oneapi/setvars.sh
:: initializing oneAPI environment ...
:: advisor -- latest
:: intelpython -- latest
:: vtune -- latest
:: tbb -- latest
:: dnnl -- latest
:: mkl -- latest
:: dev-utilities -- latest
:: dpcpp-ct -- latest
:: ipp -- latest
:: daal -- latest
:: mpi -- latest
:: ccl -- latest
:: ippcp -- latest
:: compiler -- latest
:: vpl -- latest
:: debugger -- latest
:: oneAPI environment initialized ::
$ oneapi-cli
Connecting to online Sample Aggregator, this may take some time based on network conditions
2020/09/17 12:39:08 character set not supported

0 Kudos
Highlighted
Moderator
74 Views

How about this command:

LANG=en_GB.UTF-8 oneapi-cli

 

Does it work?

 

0 Kudos
Highlighted
Employee
56 Views

No, but that would have been surprising given it's the same as the $export LANG=UTF-8 I did above, isn't it?

BTW: I do not need this fixed for myself. It's just a bug I found and wanted to report.

0 Kudos
Highlighted
Moderator
50 Views

Hi,

 

The reason I had asked you to try is, when I ran the below command:

LANG=en_GB.ISO-8859-15 oneapi-cli

I get the "Character set not supported" error.

 

But when I change it to:

LANG=en_GB.UTF-8 oneapi-cli

It works absolutely fine.

 

Thanks for patiently trying out all the commands (despite being similar), just wanted to be double sure before I consider it as a bug.

 

Could you please provide your base-toolkit version details?

If you are using the latest beta-09 build, did you by any chance also notice this issue with the older versions?

 

Meanwhile, you may access the samples on https://github.com/oneapi-src/oneAPI-samples.

 

Thanks for reporting this issue and thank you very much for your time.

 

Regards,

Rahul

0 Kudos
Highlighted
Employee
41 Views

Hi Rahul,

sorry, I hope my last post didn't appear annoyed - that wasn't my intention

I have not tried any of the older version. This is mine:

$ apt-cache policy intel-basekit
intel-basekit:
Installed: 2021.1-2195.beta09
Candidate: 2021.1-2195.beta09
Version table:
*** 2021.1-2195.beta09 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
100 /var/lib/dpkg/status
2021.1-1970.beta08 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
2021.1-1506.beta07 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
2021.1-1113.beta06 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
2021.1-720.beta05 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
2021.1-423.beta04 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages
2021.1-85.beta03 500
500 https://apt.repos.intel.com/oneapi all/main amd64 Packages

Thanks!

0 Kudos
Highlighted
Moderator
30 Views

Hi,


Forwarding this issue to the concerned team. They will get back to you shortly.



Thanks,

Rahul


0 Kudos