Intel® oneAPI Data Analytics Library
Learn from community members on how to build compute-intensive applications that run efficiently on Intel® architecture.

DAAL installation via Parallel Studio XE error at system start-up


I have installed Parallel Studios successfully and am trying to link Intel compilers to R, however I cannot get that far because I am first having issues with DAAL. When I start my system, it seems that the DAAL examples are all being run via:


From the error messages I am receiving (one for each of the ~160 examples!), I see the `daal` module is not able to be imported when running the examples. This is because the script is being run with the system Python3, so no DAAL or MKL etc is available to it. Here is the bug report, where I have marked the parts I found useful:



  1. why is this script even being run at startup?
  2. how can I prevent it from being run?
  3. What other options do I have, apart from uninstalling everything?

I thought I might try a work around and simply set my PATH so that the Intel Python Distribution is the first found. I did this, so `echo $PATH` shows that folder first. This didn't work though, the error messages still show the Ubuntu system Python being used for the DAAL examples.

Environment Setup

I have included the setup file from Parallel Studios in my start-up script, i.e. i have a file "" in `/etc/profile.d/`, which is run at start-up via the file `/etc/profile`. This `` script simply contains:

source /opt/intel/parallel_studio_xe_2017.3.053/bin/

I have also tried running the explicit `` file in my startup bash, but that didn't change anything. It just meant environment variables were defined twice.

I am running Ubuntu 16.04. Here are the places where DAAL is found in my environment:

n1k31t4@n1k31t4:~$ env | grep daal | tr \: \\n


0 Kudos
3 Replies

I couldn't get this to work and had to uninstall Parallel Studio XE. This also lead to problems as the uninstaller didn't remove everything and left some crash reports active and so in a loop in Apport. If anyone can provide an installation guide for the icc and ifort compilers, and how to link the to R for statistics, I would be very grateful. There is a guide here: - but is doesn't work anymore on up-to-date systems. It is also written rather confusingly, setting environment variables explicitly, then also defining them once again in the configure command.

0 Kudos

Hi N K,

We are sorry for the situation.  Do you install the parallel studio xe package 2017 update 3 on Ubuntu ?  We will try it and get back to you later.

Regarding your questions Regarding DAAL: right, is python script. if it was run at start up. It should be called in some places.  But currently, you had uninstalled Parallel studio XE,  does it still run?  could you please try some system tools like >ps -aux to see all process.  I suppose it is gone.

Then let's consider your original question,  trying to link only Intel compilers and MKL to R.  So you only need Intel Compiler and MKL, right?

Then May you choose custom install Parallel studio XE, then select  only compiler and MKL.  Thus no DAAL component, not it's example.  

Best Regards,


0 Kudos

Hi Ying,

thanks for your reply. I had installed Parallel Studio XE - the latest update which I believe was Update 3 - on Ubuntu 16.04.

The problems I had at login with repeated warning about each of the Python test scripts was because they had failed once, and the error were recorded by Apport, which seemed to try resolving the errors by automatically running them again (I can't think of another cause). I found this to be true only after having uninstalled everything to do with Parallel Studios (and other Intel things such as the Python Distributions) because there was no way for the scripts to be run if they were not present. I removed all the crash reports stored by Apport, which solved the issue.

I installed Parallel Studios again, but only with the C/C++ and Fortran compilers selected (I think that was all, at least there was definitely no DAAL selected). I also installed the Intel Python Distributions (latest versions for both Python2 and Python3). They work fine now and I was also able to successfully compile and install R from CRAN (version 3.3.3) with links to the MKL libraries, using the Intel compilers: icc and ifort. I followed this great tutorial for that:

It is a shame because I did want to try out some of the advanced Intel toolkits for performance analysis and so on. For me as a standalone user, however, the time required to learn how to install everything in a stable way just isn't plausible.

Maybe I will try again in the future. Thanks gain for your reply,


0 Kudos