Intel® oneAPI Data Analytics Library
Community support for building compute-intensive applications that run fast on Intel® architecture.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

Which GNU C/C++ version is required?

joachim_d_
Beginner
218 Views

Hi there, as there are two conflicting answers on this, the open source version on GIthub claims

GNU C/C++ 5.1 here (https://github.com/01org/daal)

but in the Getting started guide system requirements on the Intel website (https://software.intel.com/en-us/articles/intel-daal-2016-system-requirements)

it says

GNU C/C++ 4.9

 

 

0 Kudos
1 Solution
Ilya_B_Intel
Employee
218 Views

Hi, Joachim

If you take pre-built version of the library, you will be able to use it with GCC 4.9+

In order to build library from sources, you will need GCC 5.1+.

View solution in original post

2 Replies
Ilya_B_Intel
Employee
219 Views

Hi, Joachim

If you take pre-built version of the library, you will be able to use it with GCC 4.9+

In order to build library from sources, you will need GCC 5.1+.

joachim_d_
Beginner
218 Views

Excellent thank you I am using the prebuild-version and it seems to work fine with GCC4.9.2 

Reply