Intel® oneAPI Data Parallel C++
Support for Intel® oneAPI DPC++ Compiler, Intel® oneAPI DPC++ Library, Intel® DPC++ Compatibility Tool, and GDB*

Core dumped when executing


I am trying to execute the FPGA_tutorial__Compile_Flow. I have followed the instructions to install OneAPI Base Toolkit and the Intel-FPGA Add-on for Base Kit in a Linux Environment with Ubuntu 18.04. I don't  have the acceleration card installed but I have executed the aocl install (with an error in the final step because the HW is not present). I can generate the project using Eclipse but when I execute the application using the FPGA_EMULATOR it generates a "core dumped".

Debugging the application in Eclipse the error is raised in the execution of the call to deviceQueue.reset

try {
 -->   deviceQueue.reset( new queue(device_selector, async_handler{}) );

Any advice of what could be the problem?

Can I run this example with the FPGA EMULATOR without the hardware installed?

When I compile the example for  CPU (make compile_flow.cpu_host) I also get a "core dumped"

0 Kudos
4 Replies

Hi Mariano,

Yes, you can run with FPGA Emulator. we tried to reproduce the same issue on ubuntu 18.04 and oneAPI base kit version 2021.1-beta02, and it is working fine for both FPGA Emulator and CPU without any “core dumped”.

Can you provide details about oneAPI toolkit version that you are using, so that we can investigate more on it?


0 Kudos

Hi Goutham:

Thanks you for your help.

Bellow are the steps followed to install the software and generate the examples.

Hope this helps to find the problem.

Regards, Mariano Ruiz

Universidad Politecnica de Madrid


Steps followed.

Software Installation
1.- l_BaseKit_b_2021.1.2.047_offline
gedit silent.cfg
sudo ./ --silent ./silent.cfg
cd /opt/intel/inteloneapi/
aocl install
2.-  l_intel_fpga_dpcpp_2021.1-beta01/
sudo ./
gedit silent.cfg
sudo ./ --silent ./silent.cfg

test of the application

Open a terminal command

1./ Setting the environment variables

mruiz@mruiz-Precision-Tower-3420:~$ source /opt/intel/inteloneapi/
::  initializing environment ...
   advisor -- latest
Copyright (C) 2009-2019 Intel Corporation. All rights reserved.
Intel(R) Advisor 2021.1 (build 603889)
   ccl -- latest
   compiler -- latest
   daal -- latest
   debugger -- latestI attach you a document describing
   dev-utilities -- latest
   dnnl -- latest
   dpcpp-ct -- latest
   intelfpgadpcpp -- latest
   intelpython -- latest
   ipp -- latest
   mkl -- latest
   mpi -- latest
   tbb -- latest
   vpl -- latest
Configuring enviroment for VPL...
Adding /opt/intel/inteloneapi/vpl/latest/include to CPATH...
Adding /opt/intel/inteloneapi/vpl/latest/lib to LIBRARY_PATH and LD_LIBRARY_PATH...
Setting VPL_EXTENSIONS_PATH to /opt/intel/inteloneapi/vpl/latest/lib
   vtune -- latest
Copyright (C) 2009-2019 Intel Corporation. All rights reserved.
Intel(R) VTune(TM) Profiler 2021.1-beta02 (build 604121)
:: oneAPI environment initialized ::

2.- verifying
mruiz@mruiz-Precision-Tower-3420:/opt/intel/inteloneapi$ ./ -v
Checking system, will report any issues.  Pass in the -v flag for verbose output
:  advisor -- latest
:  ccl -- latest
component directory /opt/intel/inteloneapi/ccl/latest does not have a file
:  compiler -- latest
Warning: Intel OPAE driver was not found.
         If Intel?? Programmable Acceleration Card with Intel?? Arria??GX FPGA is
         installed in the system, please install Intel?? OPAE driver by running:
             aocl install
:  conda_channel -- latest
component directory /opt/intel/inteloneapi/conda_channel/latest does not have a file
:  daal -- latest
component directory /opt/intel/inteloneapi/daal/latest does not have a file
:  debugger -- latest
component directory /opt/intel/inteloneapi/debugger/latest does not have a file
:  dev-utilities -- latest
:  dnnl -- latest
component directory /opt/intel/inteloneapi/dnnl/latest does not have a file
:  dpcpp-ct -- latest
:  etc -- latest
component directory /opt/intel/inteloneapi/etc/latest does not have a file
:  intelfpgadpcpp -- latest
:  intelpython -- latest

ERROR: test_smoke (__main__.TestIntelDistribution) (package='cython')
Traceback (most recent call last):
  File "/opt/intel/inteloneapi/intelpython/python3.7/sys_check/", line 80, in test_smoke
    raise err
  File "/opt/intel/inteloneapi/intelpython/python3.7/sys_check/", line 77, in test_smoke
  File "/opt/intel/inteloneapi/intelpython/latest/lib/python3.7/", line 487, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command 'python "/opt/intel/inteloneapi/intelpython/latest/pkgs/cython-0.29.13-py37ha68da19_0/info/test/"' returned non-zero exit status 1.

Ran 4 tests in 8.195s

FAILED (errors=1)

:  ipp -- latest
component directory /opt/intel/inteloneapi/ipp/latest does not have a file
:  licensing -- latest
component directory /opt/intel/inteloneapi/licensing/latest does not have a file
:  mkl -- latest
component directory /opt/intel/inteloneapi/mkl/latest does not have a file
:  mpi -- latest
component directory /opt/intel/inteloneapi/mpi/latest does not have a file
:  pset -- latest
component directory /opt/intel/inteloneapi/pset/latest does not have a file
:  tbb -- latest
:  vpl -- latest
VPL was found: /opt/intel/inteloneapi/vpl/latest
No issues encountered.
:  vtune -- latest
OS version supported.
dpkg package found.
Found GTK3 package.
Found libXScrnSaver package.
Found libnss3 library: version=2:3.35.
Corrected libnss3 version=3.35.
Found asound library.
Found Xorg server package.
Found pango library.
Completed checking GUI prerequisites for oneAPI VTune(TM) Profiler.
Version of kernel is correct
Found correct kernel headers
Found libc6 library: version=2.27.
glibc library version is correct.
No Issues Encountered

I get the error becuase the hardware is not present.

3.-running eclipse in the same terminal window
./Downloads/eclipse-cpp-2019-03-R-linux-gtk-x86_64/eclipse/eclipse &
4.-Creating a empty workspace /home/mruiz/testoneapi
a. File->New->Browse Intel samples
b. Select. Intel oneAPI Base Toolkit->DPC++ Compiler-|FPGA tutorail: Compile Flow
c. Select Finish. Project created correclty
d. In the project. Build Configurations-> Create FPGA Build Configs. A window apperas. Clickon OK for the default emulation mode.
e. Set Active. Already activated the FPGA emulation.
f. Project Build. The console does not display any error.
compile_flow.fpga_emu is generated in the build/FPGA_emulator_debug. Debugging: Crashes
Output of Eclipse stack.
compile_flow.fpga_emu [C/C++ Application]    
    compile_flow.fpga_emu [7368] [cores: 3]    
        Thread #1 [compile_flow.fp] 7368 [core: 3] (Suspended : Signal : SIGSEGV:Segmentation fault)    
            acl_hal_mmd_get_device_memory_support() at 0x7fffefecb2f0    
            acl_svm_device_supports_physical_memory() at 0x7fffefea052f    
            l_finalize_context() at 0x7fffefee8ca5    
            clCreateContextIntelFPGA() at 0x7fffefee905e    
            clGetDeviceInfoIntelFPGA() at 0x7fffefea0cc1    
            cl::sycl::detail::platform_impl_pi::get_devices(cl::sycl::info::device_type) const at 0x7ffff7f6e6b4    
            cl::sycl::platform::get_devices(cl::sycl::info::device_type) const at 0x7ffff7f9d06d    
            cl::sycl::detail::platform_impl_pi::get_platforms() at 0x7ffff7f6d61c    
            cl::sycl::platform::get_platforms() at 0x7ffff7f9d0a4    
            cl::sycl::device::get_devices() at 0x7ffff7f989c6    
            cl::sycl::device_selector::select_device() const at 0x7ffff7f99747    
            cl::sycl::queue::queue() at queue.hpp:41 0x4285a4    
            main() at compile_flow.cpp:48 0x426bc2    
    gdb (    



0 Kudos


Thanks for the details. We will investigate and get back to you as soon as possible.


0 Kudos


This FPGA issue needs a FPGA expert to look at and can not be handled here. Please report your issue to the Intel® High Level Design Forum. 

Thank you!


0 Kudos