Intel® oneAPI Data Parallel C++
Support for Intel® oneAPI DPC++ Compiler, Intel® oneAPI DPC++ Library, Intel® DPC++ Compatibility Tool, and GDB*
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

failed to load igfxdcd into kernel

syk1
Employee
964 Views

I am tring to install igfxdcd to debug dpcpp file according to this link

(https://software.intel.com/content/www/us/en/develop/documentation/get-started-with-debugging-dpcpp...)

igfxdcd-1.8.0-Linux.deb is installed successfully, I can see compiled igfxdcd.ko under /lib/modules/5.4.0-77-generic/updates/dkms/

modinfo igfxdcd also shows something.

But modprobe igfxdcd failed with root user

modprobe: ERROR: could not insert 'igfxdcd': Operation not permitted

 

Kernel I am running is also same as kernel installed

 

root@station:/home/# uname -a
Linux 5.4.0-77-generic #86-Ubuntu SMP Thu Jun 17 02:35:03 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

 

Do you have any idea on this and can provide some help?

My environment is ubuntu 20.04 on i7-10700K with a gen9 GPU

the oneAPI version is BaseKit_p_2021.3.0.3219

Thanks

0 Kudos
8 Replies
syk1
Employee
956 Views

secure boot is turned off in this computer

ShivaniK_Intel
Moderator
924 Views

Hi,

 

Thanks for reaching out to us.

 

Could you please let us know whether the latest GPU drivers are installed on your system? If yes, please provide the version of GPU drivers.

 

If not, you can install the latest GPU drivers from the following link below.

 

https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-focal.html

 

Thanks & Regards

Shivani

 

syk1
Employee
917 Views

Hi Shivani,

 

Yes, I have follow the instructions and install the latest driver on ubuntu.

I thought the reason should be my GPU is not included in official released igfxdcd 1.8.0

in the source code of igfxdcd, there is only 1 devide registered for commet lake (0x9BCA) in /usr/src/igfxdcd-1.8.0/skus.h

My device 0x9bc5 is not included.

output of lspci is:

00:02.0 VGA compatible controller: Intel Corporation Device 9bc5 (rev 05)

 

Thanks,

Yuankun

syk1
Employee
865 Views

Hi Shivani,

 

Thanks for the update. It can still trigger the same error.

ShivaniK_Intel
Moderator
797 Views

Hi,


We are working on it and will get back to you soon.


Thanks & Regards

Shivani


Sravani_K_Intel
Moderator
765 Views

Debugger team is looking into the issue, being tracked internally under DOQG-2431.



ShivaniK_Intel
Moderator
604 Views

Hi,


Thank you for your patience. The issue raised by you has been fixed in the intel one API 2021.4 version. So, could you please download and let us know if this resolves your issue.


Thanks & Regards

Shivani


ShivaniK_Intel
Moderator
537 Views

Hi,


I have not heard back from you. This thread will no longer be monitored by Intel. If you need further assistance please post a new question.


Thanks & Regards

Shivani


Reply