Community
cancel
Showing results for 
Search instead for 
Did you mean: 
348 Views

[-1] MPI startup(): Imported environment partly inaccesible

Hi,

If I start the IMB-MPI1 benchmark (or others programs) with "mpirun -genv I_MPI_DEBUG 5", I get:
[bash][-1] MPI startup(): Imported environment partly inaccesible[/bash]
How can I solve this problem ?

Thx a lot,
best regards
Guillaume
0 Kudos
6 Replies
James_T_Intel
Moderator
348 Views

Hi Guillame,

I have seen this message, and I have never noticed a problem related to it. I am checking with others to get an explanation for the cause of themessage and if it could point to another possible problem.

Sincerely,
James Tullos
Technical Consulting Engineer
Intel Cluster Tools
348 Views

Hi,

On the cluster, the intel suite is installed on the frontend and then, the directory is exported to the nodes. Can the error/warning message come from that ?

If the intel suite is just installed on the frontend and then exported via NFS, do we have to do anything special during the installation ? special options...?

Thx a lot
Guillaume
James_T_Intel
Moderator
348 Views

Hi Guillame,

Installing on a shared location is perfectly fine. That's actually the setup I have on most of the systems I use for testing.

What I've been told about thatmessage is that it is due to process pinning being disabled for any reason. So unless you are using process pinning, this message is not a concern. However, it is confusing, and there is now a push to change it.

Sincerely,
James Tullos
Technical Consulting Engineer
Intel Cluster Tools
348 Views

THx for your answer. So the message is not relevant for us.

But in order to install on a shared location, shall we enable special options during the installation or just do a standard installation ?

Thx
James_T_Intel
Moderator
348 Views

Hi Guillame,

There's no difference in installing on a shared vs. non-shared location as far as installation procedure. Your license might restrict this, but that is a separate issue.

Sincerely,
James Tullos
Technical Consulting Engineer
Intel Cluster Tools
Anatoliy_R_Intel
Employee
348 Views

Hi Guillaume,

 

This warning message should not be printed if you are using mpirun. Which Intel MPI version do you use? Could you please provide full command line and full debug output? Please also run `mpirun -l -genv I_MPI_DEBUG 5 env`

--

Best regards, Anatoliy

 

Reply