Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Zhenzhen_B_
Beginner
167 Views

Can't install Parallel Studio XE 2015 Update1 on Scientific Linux 6.6

When I install Parallel Studio XE 2015 Update1 on Scientific Linux 6.6, the message shows:

-------------------------------------------------------------------------------------------------------------------------------------

Missing optional prerequisites

-- Intel(R) MPI Library, Development Kit 5.0 Update 1 for Linux* OS: Unsupported OS

-- Intel(R) Trace Analyzer and Collector 9.0 Update 1 for Linux* OS: Unsupported OS

-- Intel(R) VTune(TM) Amplifier XE 2015: Unsupported OS

-- Intel(R) Inspector XE 2015: Unsupported OS

-- Intel(R) Advisor XE 2015: Unsupported OS

-- Intel(R) Parallel Studio XE 2015 Composer Edition for C++ Linux*: Unsupported OS

-- Intel(R) Parallel Studio XE 2015 Composer Edition for Fortran Linux*: Unsupported OS

-- Intel(R) Parallel Studio XE 2015 Composer Edition for Fortran and C++ Linux*: Unsupported OS

----------------------------------------------------------------------------------------------------------------------------------------

And when I type a selection [2] to show the detailed info about issue(s), it shows:

Step 1 of 6 | Prerequisites > Missing Optional Prerequisite

----------------------------------------------------------------------------------------------------------------------------------------

Detected operating system is not supported. Supported operating system for this release are:

    - Ubuntu* 12.04 (Intel(R) 64), 14.04 (Intel(R) 64);

    - SUSE Linux Enterprise Server* 11 (Intel(R) 64), 12  (Intel(R) 64);

    - Red Hat Enterprise Linux* 6 (Intel(R) 64), 7  (Intel(R) 64);

    - Fedora* 20 (Intel(R) 64), 21  (Intel(R) 64);

    - Debian* 6.0 (Intel(R) 64), 7.0  (Intel(R) 64);

    - CentOs* 6  (Intel(R) 64);

----------------------------------------------------------------------------------------------------------------------------------------

When I skipped missing optional prerequisites and installed it by default, I could not find "psxevar.sh" in subdirectory "/opt/intel/parallel_studio_xe_2015". I thought I must have lost some critical components of Parallel Studio XE 2015 Update1.

Does it mean that I can not install Parallel Studio XE 2015 Update1 on Scientific Linux 6.6?

While, I was told that Scientific Linux is very similar with Red Hat Enterprise Linux. So how could I install Parallel Studio XE 2015 Update1 on Scientific Linux 6.6?

Thank you very much!

0 Kudos
6 Replies
Shaolong_C_
Beginner
167 Views

I think you should try the version 2013

我们实验室装的就是2013版的

Gergana_S_Intel
Employee
167 Views

Hi Zhenzhen,

Thanks for getting in touch.  It's true that Scientific Linux is not a supported Operating System distribution but I believe it should work since it's so similar to Red Hat.

You mention that the "psxevar.sh" file was missing after install.  Can you double-check the spelling of the file?  It should be called psxevars.sh.  Here's an example:

[gergana@host1 ~]$ ls /opt/intel/parallel_studio_xe_2015/psxevars.sh
/opt/intel/parallel_studio_xe_2015/psxevars.sh

If the psxevars.sh file does not exist, please provide the install log (usually created in /tmp on the node where you started the installation).  That will help us determine what the root cause of the issue might be.

Best regards,
~Gergana

Zhenzhen_B_
Beginner
167 Views

Thanks for helping me very much, a teacher helped me and successfully installed Parallel Studio XE 2015 Update1 on Scientific Linux 6.6 at last. 

The reason why I failed to install before was that the network connection was instable and I downloaded an incomplete package /(ㄒoㄒ)/~~

Luis_Agustin_N_
Beginner
167 Views

Hi! could you be more specific about how do you  it? thanks!

Reza_M_1
Beginner
167 Views

hello Guys, 

I have same problem installing Parallel Studion, cluster version on Scientific Linux. 

 

i can finish installation but when i run the psxevars.sh nothing will be set in envirounment variables.

After using " which mpirun" command system cannot find any path.

 

anybody knows what is wrong ?

Regards,

Zhenzhen_B_
Beginner
167 Views

Dear Reza M:

I suppose you should try: ./psxevars.sh ia32 or ./psxevars.sh intel64 instead of ./psxevars.sh

If that still can not help, I suggest you editing your .bash_profile or .bashrc file.

I edit my .bash_profile manually as follows:

# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
    . ~/.bashrc
fi

# User specific environment and startup programs

source /home/soft/intel/parallel_studio_xe_2015/psxevars.sh ia32

source /home/soft/intel/parallel_studio_xe_2015/psxevars.sh intel64

source /home/soft/intel/impi/5.0.2.044/bin64/mpivars.sh intel64

CPATH=$CPATH:/home/soft/intel/include

export INCLUDE=$INCLUDE:/home/soft/intel/include

export I_MPI_MPD_RSH=ssh
export I_MPI_USE_DYNAMIC_CONNECTIONS=0
export I_MPI_FABRICS_LIST="ofa,dapl,tcp,tmi"
export I_MPI_DEBUG=5
export I_MPI_FALLBACK_DEVICE=1

Hope that can help you!

Regards.

Reply