Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Simon_H_3
Beginner
155 Views

Compiling Intel Linpack MP Benchmark mpiicc error

Hello!  I am new to Intel Linpack Benchmark.  I downloaded the evaluation version of Intel Parallel Studio XE Cluster Edition.  I followed the directions and was able to run the single system benchmark and got about 340Gflops.  When I tried to compile the mp_linpack... I get some error with not finding mpiicc.  I did find mpiicc in I believe /opt/intel/ directory and I added the directory to $PATH.  But when compiling, it shows error mpiicc not found...  I changed the Make file to use mpicc and it compiled... but I am trying to use Intel mpiicc to get the best result.  

Anyone had previous experience with this error?  

OS is SL 6.6

Thanks!  

Simon.

0 Kudos
4 Replies
Steve_H_Intel1
Employee
155 Views

 

Simon,

   From a login session, what happens when you issue the command:

         which mpiicc

Secondly, have you sourced either "psxevars.sh" or "psxevars.csh" depending on the Shell interface that you are using?

-Steve

Simon_H_3
Beginner
155 Views

Thanks for your help!  It looks like I didn't have to recompile from source.  I am now using the precompiled intel_64 bin and run the mpirun command.  

It took me a while to figure out...

Cheers!

Simon.

Steve_H_Intel1
Employee
155 Views

Simon,

    I am glad to hear that this problem is resolved.

-Steve

VISWANATHAN_E_
Beginner
155 Views

Hi all

 

In relating to the above, I get the following issue while running or calling the mpi-version of intel compiler or libraries. Can any one suggest a solution? 

I installed the parallel_studio_xe_2015_update6 and trying to compile fortran program with mpiifort (but when I use ifort, there are no issue). But I get the following issue. I understand the issue comes from path linking to compiler or libraries. I checked my environmental setup in .bashrc

source /opt/intel/composer_xe_2015.6.233/bin/compilervars.sh intel64
source /opt/intel/impi/5.0.3.049/bin64/mpivars.sh

 

they are fine. But still the linking issue is 

$ which mpiifort

$ /opt/intel//impi/5.0.3.049/intel64/bin/mpiifort

I suspect the additional forward slash making this issue. Is there any solution.

thanks

vis

Reply