Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
27 Views

Does Intel MPI library work on Intel Xeon 5600 processors

I don't need to compile on a Xeon 5600, but I need to be able to run on them.  Either the 2019 version, or an older version as long as I can still download it.

It just says Intel 64 or Intel Xeon series processors in some places, but says Intel E5 or E7 recommended in other places.  There's a bazillion Xeon processors, and I don't know how they relate to one another.

0 Kudos
2 Replies
Highlighted
Employee
27 Views

Hello Michael,

Intel MPI Library 2019 Update 4 will work on Xeon 5600 but performance can be suboptimal there. You can still download 2017 Update 4. BTW 2018 Update 5 became generally available last week.

--

Best regards, Yury.

0 Kudos
Highlighted
Beginner
27 Views

Thanks, but now I'm a little worried about what suboptimal means.  It will still use the cores in parallel, right?  I ran into that problem on a test computer, my CPUs (Core i5, not Xeon 5600) were so old that they wouldn't work in parallel.  It's a big purchase to then find out it won't work on the computer we're targeting.  Are you saying that 2017 Update 4, or 2018 Update 5 would be better to use?

0 Kudos