Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Wilkes__Chris
Beginner
923 Views

Errors when trying to use Intel MPI yum/apt repos

Jump to solution

Just noticed these errors when trying to use MPI 2018 for Centos and 2019 for Ubuntu 16

Yum errors:

$ sudo yum update -y

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: repos.lax.layerhost.com
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: mirror.dal10.us.leaseweb.net
 * updates: mirror.dal10.us.leaseweb.net
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
STDERR: Failed to set locale, defaulting to C
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

 

Apt errors:

 

$ apt-get -y install intel-mpi-2019.6-088

Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
intel-comp-l-all-vars-19.1.0-166 intel-comp-nomcu-vars-19.1.0-166
intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
intel-conda-index-tool-19.1.0-166 intel-imb-2019.6-166 intel-mpi-doc-2019
intel-mpi-psxe-2019.6-088 intel-mpi-rt-2019.6-166
intel-mpi-samples-2019.6-166 intel-mpi-sdk-2019.6-166
intel-psxe-common-2020.0-088 intel-psxe-common-doc-2020
The following NEW packages will be installed:
intel-comp-l-all-vars-19.1.0-166 intel-comp-nomcu-vars-19.1.0-166
intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
intel-conda-index-tool-19.1.0-166 intel-imb-2019.6-166 intel-mpi-2019.6-088
intel-mpi-doc-2019 intel-mpi-psxe-2019.6-088 intel-mpi-rt-2019.6-166
intel-mpi-samples-2019.6-166 intel-mpi-sdk-2019.6-166
intel-psxe-common-2020.0-088 intel-psxe-common-doc-2020
0 upgraded, 14 newly installed, 0 to remove and 3 not upgraded.
Need to get 95.8 MB of archives.
After this operation, 0 B of additional disk space will be used.


WARNING: The following packages cannot be authenticated!
intel-mpi-doc-2019 intel-mpi-rt-2019.6-166
intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
intel-imb-2019.6-166 intel-mpi-psxe-2019.6-088 intel-mpi-samples-2019.6-166
intel-mpi-sdk-2019.6-166 intel-mpi-2019.6-088

There were unauthenticated packages and -y was used without --allow-unauthenticated

 

0 Kudos
1 Solution
ArpanB_Intel
Moderator
185 Views

Chris, we have been intimated that the servers are back up now. Please let us know if you are still facing the issues.


View solution in original post

20 Replies
Wilkes__Chris
Beginner
910 Views

Seems to boil down to a misconfigured yum repo server with 23.222.195.98 returning a 403

 

$ wget https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc
--2021-04-21 11:39:07-- https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc
Resolving yum.repos.intel.com (yum.repos.intel.com)... 104.81.176.228, 2001:559:19:2885::4b23, 2001:559:19:289e::4b23
Connecting to yum.repos.intel.com (yum.repos.intel.com)|104.81.176.228|:443... connected.
HTTP request sent, awaiting response... 200 OK

 

$ wget https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc
--2021-04-21 18:38:55-- https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc
Resolving yum.repos.intel.com (yum.repos.intel.com)... 23.222.195.98, 2600:1407:5800:381::4b23, 2600:1407:5800:393::4b23
Connecting to yum.repos.intel.com (yum.repos.intel.com)|23.222.195.98|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden

 

 

Wilkes__Chris
Beginner
889 Views

Now I'm also seeing errors when trying to do a apt update:

Failed to fetch https://apt.repos.intel.com/mpi/dists/all/main/binary-amd64/Packages Writing more data than expected (117858 > 110051)

Also (on a different VM):

Failed to fetch https://apt.repos.intel.com/mpi/dists/all/main/binary-amd64/Packages Writing more data than expected (112050 > 110051)

 

Wilkes__Chris
Beginner
769 Views

Now I'm seeing this error:

 

$ sudo apt-get update
Hit:1 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 https://apt.repos.intel.com/intelpython binary/ InRelease
Hit:5 https://apt.repos.intel.com/mkl all InRelease
Hit:6 https://apt.repos.intel.com/ipp all InRelease
Hit:7 https://apt.repos.intel.com/tbb all InRelease
Hit:8 https://apt.repos.intel.com/daal all InRelease
Hit:9 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:10 http://archive.canonical.com/ubuntu xenial InRelease
Ign:11 https://apt.repos.intel.com/mpi all InRelease
Hit:12 https://apt.repos.intel.com/mpi all Release
Ign:13 https://apt.repos.intel.com/mpi all Release.gpg
Reading package lists...

W: The repository 'https://apt.repos.intel.com/mpi all Release' is not signed.

 

Then trying to install from it:

 

$ sudo DEBIAN_FRONTEND='noninteractive' /usr/bin/apt-get -y install intel-mpi-2019.6-088
STDOUT: Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  intel-comp-l-all-vars-19.1.0-166 intel-comp-nomcu-vars-19.1.0-166
  intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
  intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
  intel-conda-index-tool-19.1.0-166 intel-imb-2019.6-166 intel-mpi-doc-2019
  intel-mpi-psxe-2019.6-088 intel-mpi-rt-2019.6-166
  intel-mpi-samples-2019.6-166 intel-mpi-sdk-2019.6-166
  intel-psxe-common-2020.0-088 intel-psxe-common-doc-2020
The following NEW packages will be installed:
  intel-comp-l-all-vars-19.1.0-166 intel-comp-nomcu-vars-19.1.0-166
  intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
  intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
  intel-conda-index-tool-19.1.0-166 intel-imb-2019.6-166 intel-mpi-2019.6-088
  intel-mpi-doc-2019 intel-mpi-psxe-2019.6-088 intel-mpi-rt-2019.6-166
  intel-mpi-samples-2019.6-166 intel-mpi-sdk-2019.6-166
  intel-psxe-common-2020.0-088 intel-psxe-common-doc-2020
0 upgraded, 14 newly installed, 0 to remove and 2 not upgraded.
Need to get 95.8 MB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  intel-mpi-doc-2019 intel-mpi-rt-2019.6-166
  intel-conda-impi-rt-linux-64-shadow-package-2019.6-166
  intel-conda-impi-devel-linux-64-shadow-package-2019.6-166
  intel-imb-2019.6-166 intel-mpi-psxe-2019.6-088 intel-mpi-samples-2019.6-166
  intel-mpi-sdk-2019.6-166 intel-mpi-2019.6-088
E: There were unauthenticated packages and -y was used without --allow-unauthenticated
Wilkes__Chris
Beginner
762 Views

Yum error is now slightly different:

 

$ sudo yum update -y

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.s.uw.edu
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: repos.forethought.net
 * updates: repos.lax.layerhost.com
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Failed to set locale, defaulting to C
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
 Userid     : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
 Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
https://yum.repos.intel.com/mpi/repodata/repomd.xml: [Errno -1] repomd.xml signature could not be verified for intel-mpi-repo
Trying other mirror.
Wilkes__Chris
Beginner
709 Views

Still getting errors (4/26):

 

Failed to fetch https://apt.repos.intel.com/mpi/dists/all/main/binary-amd64/Packages  Writing more data than expected (117858 > 110051)
E: Some index files failed to download. They have been ignored, or old ones used instead.

 From       : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
https://yum.repos.intel.com/mpi/repodata/repomd.xml: [Errno -1] repomd.xml signature could not be verified for intel-mpi-repo
Trying other mirror.

Wilkes__Chris
Beginner
673 Views

Still getting an error with both the yum and apt repos.  I'm able to use the oneAPI repo but that only has MPI 2021 and not 2018 and 2019.

Yum:

Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

STDERR: Failed to set locale, defaulting to C
Importing GPG key 0x1911E097:
Userid : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
From : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
Userid : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
From : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
Userid : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
From : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
Userid : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
From : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
https://yum.repos.intel.com/mpi/repodata/repomd.xml: [Errno -1] repomd.xml signature could not be verified for intel-mpi-repo
Trying other mirror.

 

apt:

$ sudo apt-get update
STDOUT: OK
Hit:1 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://us-west1.gce.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:4 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:5 http://archive.canonical.com/ubuntu xenial InRelease
Get:6 https://apt.repos.intel.com/intelpython binary/ InRelease [1,407 B]
Get:7 https://apt.repos.intel.com/mkl all InRelease [4,438 B]
Get:8 https://apt.repos.intel.com/ipp all InRelease [4,436 B]
Get:9 https://apt.repos.intel.com/tbb all InRelease [4,428 B]
Get:10 https://apt.repos.intel.com/daal all InRelease [4,438 B]
Get:11 https://apt.repos.intel.com/mpi all InRelease [4,398 B]
Get:12 https://apt.repos.intel.com/intelpython binary/ Packages [3,501 B]
Get:13 https://apt.repos.intel.com/mkl all/main amd64 Packages [108 kB]
Get:14 https://apt.repos.intel.com/mkl all/main all Packages [28.8 kB]
Get:15 https://apt.repos.intel.com/ipp all/main amd64 Packages [51.3 kB]
Get:16 https://apt.repos.intel.com/ipp all/main all Packages [15.3 kB]
Get:17 https://apt.repos.intel.com/tbb all/main amd64 Packages [26.8 kB]
Get:18 https://apt.repos.intel.com/tbb all/main all Packages [13.5 kB]
Get:19 https://apt.repos.intel.com/daal all/main amd64 Packages [34.6 kB]
Get:20 https://apt.repos.intel.com/daal all/main all Packages [12.6 kB]
Get:21 https://apt.repos.intel.com/mpi all/main amd64 Packages [18.3 kB]
Ign:21 https://apt.repos.intel.com/mpi all/main amd64 Packages
Get:22 https://apt.repos.intel.com/mpi all/main all Packages [5,813 B]
Ign:22 https://apt.repos.intel.com/mpi all/main all Packages
Get:21 https://apt.repos.intel.com/mpi all/main amd64 Packages [22.4 kB]
Ign:21 https://apt.repos.intel.com/mpi all/main amd64 Packages
Get:22 https://apt.repos.intel.com/mpi all/main all Packages [6,428 B]
Ign:22 https://apt.repos.intel.com/mpi all/main all Packages
Get:21 https://apt.repos.intel.com/mpi all/main amd64 Packages [110 kB]
Err:21 https://apt.repos.intel.com/mpi all/main amd64 Packages
Writing more data than expected (117858 > 110051)
Get:22 https://apt.repos.intel.com/mpi all/main all Packages [29.6 kB]
Ign:22 https://apt.repos.intel.com/mpi all/main all Packages
Fetched 318 kB in 1s (208 kB/s)
Reading package lists...
STDERR: E: Failed to fetch https://apt.repos.intel.com/mpi/dists/all/main/binary-amd64/Packages Writing more data than expected (117858 > 110051)
E: Some index files failed to download. They have been ignored, or old ones used instead.

ArpanB_Intel
Moderator
664 Views

Hi Chris, could you share the version CentOS you are using with 2018 MPI? The 2019 version seems to be supported by Ubuntu* LTS 16.04. We will need it to investigate further on this issue and test it ourselves.


Wilkes__Chris
Beginner
661 Views

This is "CentOS Linux release 7.9.2009 (Core)"  with kernel 3.10.0-1160.24.1.el7.x86_64 on GCP.

ArpanB_Intel
Moderator
658 Views

Chris, thank you for sharing. We will test out this issue and we will soon share our findings in this thread below.


ChanKim
Novice
598 Views

Hi, I'm having a similar issue. (I'm trying to upgrade ubuntu 16.04 to 18.04)

ckim@chan-ubuntu:~$ sudo apt-get update
[sudo] password for ckim:
Get:1 file:/var/cuda-repo-10-0-local-10.0.130-410.48 InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.130-410.48 InRelease
Get:2 file:/var/cuda-repo-9-2-148-local-patch-1 InRelease
Ign:2 file:/var/cuda-repo-9-2-148-local-patch-1 InRelease
Get:3 file:/var/cuda-repo-9-2-local InRelease
Ign:3 file:/var/cuda-repo-9-2-local InRelease
Get:4 file:/var/cuda-repo-ubuntu1604-11-1-local InRelease
Ign:4 file:/var/cuda-repo-ubuntu1604-11-1-local InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.130-410.48 Release [574 B]
Get:6 file:/var/cuda-repo-9-2-148-local-patch-1 Release [574 B]
Get:7 file:/var/cuda-repo-9-2-local Release [574 B]
Get:8 file:/var/cuda-repo-ubuntu1604-11-1-local Release [564 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.130-410.48 Release [574 B]
Get:6 file:/var/cuda-repo-9-2-148-local-patch-1 Release [574 B]
Get:7 file:/var/cuda-repo-9-2-local Release [574 B]
Get:8 file:/var/cuda-repo-ubuntu1604-11-1-local Release [564 B]
Hit:14 http://ppa.launchpad.net/nemh/systemback/ubuntu xenial InRelease
Hit:15 https://download.mono-project.com/repo/ubuntu stable-xenial InRelease
Get:16 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:17 https://apt.repos.intel.com/daal all InRelease
Hit:18 https://apt.repos.intel.com/ipp all InRelease
Hit:19 https://apt.repos.intel.com/mkl all InRelease
Hit:20 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease
Hit:21 https://packagecloud.io/github/git-lfs/ubuntu xenial InRelease
Hit:12 https://apt.llvm.org/xenial llvm-toolchain-xenial-7 InRelease
Ign:22 https://apt.repos.intel.com/mpi all InRelease
Hit:23 https://apt.repos.intel.com/tbb all InRelease
Hit:24 https://apt.repos.intel.com/intelpython binary/ InRelease
Get:25 https://apt.repos.intel.com/mpi all Release [3,865 B]
Err:26 https://apt.repos.intel.com/mpi all Release.gpg
403 Forbidden
Hit:27 http://jp.archive.ubuntu.com/ubuntu xenial InRelease
Get:28 http://jp.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Get:29 http://jp.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Get:30 http://jp.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [326 kB]
Get:31 http://jp.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [281 kB]
Get:32 http://jp.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5,976 B]
Get:33 http://jp.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3,328 B]
Get:34 http://jp.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [6,616 B]
Reading package lists... Done
E: The repository 'https://apt.repos.intel.com/mpi all Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Wilkes__Chris
Beginner
536 Views

4/30 (~10 days since this started).

 

Now seeing this error:

Hit:1 http://us-west1.gce.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://us-west1.gce.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:3 http://us-west1.gce.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:4 https://apt.repos.intel.com/intelpython binary/ InRelease [1407 B]
Get:5 https://apt.repos.intel.com/mkl all InRelease [4438 B]
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
Get:7 https://apt.repos.intel.com/ipp all InRelease [4436 B]
Get:8 https://apt.repos.intel.com/tbb all InRelease [4428 B]
Get:9 https://apt.repos.intel.com/daal all InRelease [4438 B]
Err:10 https://apt.repos.intel.com/mpi all InRelease
403 Forbidden [IP: 104.90.255.179 443]
Get:11 https://apt.repos.intel.com/intelpython binary/ Packages [3501 B]
Get:12 https://apt.repos.intel.com/mkl all/main amd64 Packages [108 kB]
Get:13 https://apt.repos.intel.com/mkl all/main all Packages [28.8 kB]
Get:14 https://apt.repos.intel.com/ipp all/main amd64 Packages [51.3 kB]
Get:15 https://apt.repos.intel.com/ipp all/main all Packages [15.3 kB]
Get:16 https://apt.repos.intel.com/tbb all/main all Packages [13.5 kB]
Get:17 https://apt.repos.intel.com/tbb all/main amd64 Packages [26.8 kB]
Get:18 https://apt.repos.intel.com/daal all/main all Packages [12.6 kB]
Get:19 https://apt.repos.intel.com/daal all/main amd64 Packages [34.6 kB]
Reading package lists...

Conflicting distribution: https://apt.repos.intel.com/intelpython binary/ InRelease (expected binary/ but got )
Failed to fetch https://apt.repos.intel.com/mpi/dists/all/InRelease 403 Forbidden [IP: 104.90.255.179 443]
The repository 'https://apt.repos.intel.com/mpi all InRelease' is not signed.

 

NilenduD_Intel
Moderator
433 Views

We are sorry for the delay and the inconvenience caused. We have tried our best but, unable to replicate the issue. Hence we are escalating this ticket to the higher team for better assistance.


Regards,

Nilendu


Wilkes__Chris
Beginner
377 Views

I'm following the steps from here:

https://software.intel.com/content/www/us/en/develop/articles/installing-intel-free-libs-and-python-...

 

Here's my history on a centos7 VM in GCP:

$ sudo yum install -y yum-utils

$ sudo yum-config-manager --add-repo https://yum.repos.intel.com/setup/intelproducts.repo

$ sudo rpm --import https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

   (hit "y" to accept the keys)

 

intel-mkl-repo/signature | 287 B 00:00:00
Retrieving key from https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Importing GPG key 0x1911E097:
Userid : ""CN = Intel(R) Software Development Products", O=Intel Corporation"
Fingerprint: bf43 85f9 1ca5 fc00 5ab3 9e1c 1a84 97b1 1911 e097
From : https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
Is this ok [y/N]: y
intel-mkl-repo/signature | 1.1 kB 00:00:01 !!!
https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below wiki article

 

 

Identifying that host:

$ host yum.repos.intel.com
yum.repos.intel.com is an alias for intel19235.edgekey.net.
intel19235.edgekey.net is an alias for e19235.dsca.akamaiedge.net.
e19235.dsca.akamaiedge.net has address 104.81.176.228
e19235.dsca.akamaiedge.net has IPv6 address 2600:1409:d000:584::4b23
e19235.dsca.akamaiedge.net has IPv6 address 2600:1409:d000:5a0::4b23

My current IP is 34.105.24.57 in case there's a problem with that.

Trying to get that file:

$ curl https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>AccessDenied</Code><Message>Access Denied</Message><RequestId>EQD63PQ63SF2AXSY</RequestId><HostId>1Q8Qo9pN8MrLxC0cKLYj/hKL7NM1UGDLel+GELdOdM7gpSGnWm9B2mVVWoL4q7DZe8Wz7agLnZg=</HostId></Error>

I also got that error when trying from my home (Comcast ISP).

ArpanB_Intel
Moderator
357 Views

Chris, we found this issue was on our end. We are currently experiencing an outage. Our internal team is currently working to resolve it as early as possible.


Wilkes__Chris
Beginner
267 Views

The https://yum.repos.intel.com/mpi/repodata/repomd.xml.asc file looks like it became available at Wed 05 May 2021 01:16:49 PM PDT.

 

However on the Ubuntu side there's a weird error when downloading a file:

 

Failed to fetch https://apt.repos.intel.com/mpi/dists/all/main/binary-all/Packages.bz2 File has unexpected size (6089 != 5813). Mirror sync in progress? [IP: 23.62.73.50 443]

 

I downloaded that file and it is that size:

$ curl -D -O https://apt.repos.intel.com/mpi/dists/all/main/binary-all/Packages.bz2

$ du -b Packages.bz2
6089 Packages.bz2

Content-Type: binary/octet-stream
Content-Length: 6089
Last-Modified: Wed, 21 Apr 2021 09:46:32 GMT
ETag: "85bc4d061210ddabf9571367a03fbbe0"
x-amz-server-side-encryption: AES256
x-amz-version-id: Yzl6QJjTXx7LaAJwamA.kOZHafs6JZbT
Accept-Ranges: bytes
Server: AmazonS3
X-Amz-Cf-Pop: SEA19-C3
X-Amz-Cf-Id: TrEwCmJlndWdvE8RX7N27UsaYtDHmYYRYYCHBI0PSnALEb0oLlL9sA==
Date: Wed, 05 May 2021 22:22:53 GMT
Connection: keep-alive
Strict-Transport-Security: max-age=31536000 ; preload

 

so I'm not sure how apt update thinks that the file should be size 5813 as the response headers say 6089 that 

 

ChanKim
Novice
252 Views

I had this 'intel/mpi repos no longer signed' error during the 'apt-get update' recently.

This morning following a suggestion from askubuntu, I commented out the repo address in the /etc/apt/sources.list.d/intel-mpi.list.

then the 'sudo apt-get update' rank ok. I'm goint to upgrade from ubuntu 16.04 to 18.04 and don't know what impact this will have on the following process but hope this helps anyone.  Ubuntu 16.04 offcial end-of-life was 2021. Apr. 30 (?around).

ArpanB_Intel
Moderator
238 Views

Chris, since our servers are down due to the outage issue, you are facing this issue. The issue has been reported and our engineers who are currently working on this. We hope to resolve this issue as early as possible.


ArpanB_Intel
Moderator
186 Views

Chris, we have been intimated that the servers are back up now. Please let us know if you are still facing the issues.


View solution in original post

Wilkes__Chris
Beginner
175 Views

Just did a run with ubuntu1804 and centos7 and both worked.  Thanks!

ChanKim
Novice
162 Views
I messed it up upgrading to ubuntu 18.04 so I fresh installed ubuntu 20.04 yesterday. If the intep mpi repo came back sooner I would have used do-release-upgrade after apt update..
Reply