Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
38 Views

I_MPI_AUTH_METHOD not working with IMPI 19 Update 3

Hi,

I moved from Intel MPI 2018 Update 4 to Intel MPI 2019 Update 3 and it seems that the new version ignores setting the user authorization method for mpirun via environment variable I_MPI_AUTH_METHOD=delegate . Setting it directly with mpiexec -delegate still works fine. Can anyone confirm that?

https://software.intel.com/en-us/mpi-developer-reference-windows-user-authorization

Thanks and kind regards,

Volker Jacht

0 Kudos
3 Replies
Highlighted
38 Views

Hello,

Thank you for finding this issue. For some reason I_MPI_AUTH_METHOD variable was not migrated to Intel MPI 2019. This variable will be available in Intel MPI 2019 Update 4. 

--

Best regards,

Anatoliy.

0 Kudos
Highlighted
Beginner
38 Views

Hi, 

I'm using update 4 (2019.4.227) on Linux and I still get:

[0] MPI startup(): I_MPI_AUTH_METHOD environment variable is not supported.
 

Thanks,

0 Kudos
Highlighted
38 Views

Hi, 

This variable works only on Windows.

But you will still see that warning message. I will turn off it in the next release. 

You can disable this warning by setting I_MPI_VAR_CHECK_SPELLING=0 variable.

--

Best regards,

Anatoliy.

0 Kudos