Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mohammad_Abu_R_
Beginner
381 Views

Installing Quantum Espresso with Intel Parallel Studio and OpenMPI

Hi,

I install the latest version of the Intel Parallel Studio and OpenMPI-2.0.1. Now when I try to install the quantum espresso I saw the following lines.

ld: warning: libifport.so.5, needed by /opt/openmpi-2.0.1/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)
ld: warning: libifcoremt.so.5, needed by /opt/openmpi-2.0.1/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)
ld: warning: libimf.so, needed by /opt/openmpi-2.0.1/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)
ld: warning: libintlc.so.5, needed by /opt/openmpi-2.0.1/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)
ld: warning: libsvml.so, needed by /opt/openmpi-2.0.1/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

And for the above I guess that I got many undefined references. I looked after the tutorial for building Quantum Espresso with Intel coprocessors "Quantum ESPRESSO* for Intel® Xeon Phi™ Coprocessor", . My make.sys file is as following,

 

TOPDIR = /media/logroup/Linux_Program_Data/DFT/Software/espresso-5.4.0

MANUAL_DFLAGS  =
DFLAGS         =  -D__OPENMP -D__INTEL -D__FFTW3 -D__MPI -D__PARA -D__SCALAPACK
FDFLAGS        = $(DFLAGS) $(MANUAL_DFLAGS)

IFLAGS         = -I../include -I/opt/intel/compilers_and_libraries_2017.0.098/linux/mkl/include/fftw

MOD_FLAG      = -I
MPIF90         = /opt/openmpi-2.0.1/bin/mpif90
#F90           = ifort
CC             = /opt/intel/compilers_and_libraries_2017.0.098/linux/bin/intel64/icc
F77            = /opt/intel/compilers_and_libraries_2017.0.098/linux/bin/intel64/ifort
CPP            = /opt/intel/compilers_and_libraries_2017.0.098/linux/bin/intel64/icc -E
CPPFLAGS       = -P -C -traditional $(DFLAGS) $(IFLAGS)
CFLAGS         = -O3 -xAVX -fno-alias -ansi-alias -g -mkl $(DFLAGS) $(IFLAGS)
F90FLAGS       = $(FFLAGS) -nomodule -qopenmp -fpp $(FDFLAGS) $(IFLAGS) $(MODFLAGS)
FFLAGS         = $(CFLAGS) -assume byterecl
FFLAGS_NOOPT   = -O0 -assume byterecl -g -traceback
FFLAGS_NOMAIN   = -nofor_main

LD             = /opt/openmpi-2.0.1/bin/mpif90
LDFLAGS        = -static-intel -qopenmp
LD_LIBS        = -L/opt/intel/lib/intel64_lin

BLAS_LIBS      =   -lmkl_intel_lp64  -lmkl_intel_thread -lmkl_core
BLAS_LIBS_SWITCH = external

LAPACK_LIBS    = -L/opt/intel/compilers_and_libraries_2017.0.098/linux/mkl/lib/intel64
LAPACK_LIBS_SWITCH = external

ELPA_LIBS_SWITCH = disabled
SCALAPACK_LIBS = -L/opt/intel/compilers_and_libraries_2017.0.098/linux/mkl/lib/intel64

FFT_LIBS       = -L/opt/intel/compilers_and_libraries_2017.0.098/linux/mkl/lib/intel64
MPI_LIBS       =
MASS_LIBS      =

AR             = /opt/intel/compilers_and_libraries_2017.0.098/linux/bin/intel64/xiar
ARFLAGS        = ruv

RANLIB         = ranlib
FLIB_TARGETS   = all

LIBOBJS        = ../clib/clib.a ../iotk/src/libiotk.a
LIBS           = $(SCALAPACK_LIBS) $(LAPACK_LIBS) $(FFT_LIBS) $(BLAS_LIBS) $(MPI_LIBS) $(MASS_LIBS) $(LD_LIBS)

It would be a great help for me if anyone could share his expertise regarding this.

Thanks a lot.

0 Kudos
1 Reply
Mohammad_Abu_R_
Beginner
381 Views

Hi,

The problem is solved by enlisting the library in /etc/lib.so.conf.d

And the problem of references are due to SCALAPACK. aftr correcting the reference, it works now.

Thanks a lot.

 

Reply