Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Heath_J_
Beginner
139 Views

Intel 2019.5, MPI compiles but does not run

I am able to compile a hello_world.c program with mpiicc but am unable to get it to run.  It works for me with Intel 2014 - 2018, but not with 2019.5.

Debugging output:

===================================================================================
hjohnson@tuxfast:/tmp/intelmpi-2019$ env I_MPI_DEBUG=6 I_MPI_HYDRA_DEBUG=on mpirun -np 1 ./a.out
[mpiexec@tuxfast] Launch arguments: /project/software/intel_psxe/2019_update1/compilers_and_libraries_2019.5.281/linux/mpi/intel64/bin//hydra_bstrap_proxy --upstream-host tuxfast --upstream-port 33709 --pgid 0 --launcher ssh --launcher-number 0 --base-path /project/software/intel_psxe/2019_update1/compilers_and_libraries_2019.5.281/linux/mpi/intel64/bin/ --tree-width 16 --tree-level 1 --time-left -1 --collective-launch 1 --debug --proxy-id 0 --node-id 0 --subtree-size 1 --upstream-fd 7 /project/software/intel_psxe/2019_update1/compilers_and_libraries_2019.5.281/linux/mpi/intel64/bin//hydra_pmi_proxy --usize -1 --auto-cleanup 1 --abort-signal 9 

===================================================================================
=   BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
=   RANK 0 PID 30410 RUNNING AT tuxfast
=   KILLED BY SIGNAL: 4 (Illegal instruction)
===================================================================================
hjohnson@tuxfast:/tmp/intelmpi-2019$ env I_MPI_DEBUG=6 I_MPI_HYDRA_DEBUG=on gdb ./a.out
...
(gdb) run
Starting program: /tmp/intelmpi-2019/a.out 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGILL, Illegal instruction.
MPL_dbg_pre_init (argc_p=0x0, argv_p=0x0, wtimeNotReady=61440) at ../../../../src/mpl/src/dbg/mpl_dbg.c:722
722     ../../../../src/mpl/src/dbg/mpl_dbg.c: No such file or directory.
(gdb) backtrace
#0  MPL_dbg_pre_init (argc_p=0x0, argv_p=0x0, wtimeNotReady=61440) at ../../../../src/mpl/src/dbg/mpl_dbg.c:722
#1  0x00001555545850fe in PMPI_Init (argc=0x0, argv=0x0) at ../../src/mpi/init/init.c:225
#2  0x0000000000400ec3 in main ()
(gdb) quit
A debugging session is active.

 

0 Kudos
1 Reply
Anatoliy_R_Intel
Employee
139 Views

Hello,

 

Please provide your processor and OS version.

--

Best regards, Anatoliy

Reply