Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Matt_Thompson
Novice
166 Views

Intel MPI, GCC, and mpi_f08

All,

This is both a question and a feature request.

First the question. What is the "correct" way for Intel MPI to support use of GCC 9? I know (as of Intel MPI 19.0.2, the latest I have access to) that it has support for GCC 4-8. I also know there is a binding kit for Intel MPI that could make bindings for Intel MPI with GCC 9. But, as far as I can tell, the mpif90/mpifc scripts have no idea GCC 9 exists. Does one need to actually edit these scripts to add a 9) case so that the scripts can find the appropriate include/ directories?

Second, the "feature request" but I'm not sure where one makes those. Namely, I was wondering if it's possible for Intel to add support for use mpi_f08 with GCC compilers. At the moment, the included bindings (and the kit) only have the F90 modules and not the F08 modules. I can see not supporting them with really old GCC, but I'm fairly certain I've built Open MPI with GCC 8 and it makes the mpi_f08 mod files just fine. I tried looking at the binding kit, but it only compiles the f90 modules as well it seems.

Thanks,

Matt

0 Kudos
1 Reply
Yury_K_Intel
Employee
166 Views

Hello Matt,

We support GCC 9.x starting Intel MPI Library 2019 Update 5. As for the F08 support with GCC we will consider adding this feature in upcoming releases.

Thank you.

--

Best regards, Yury

Reply