Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.

Intel MPI installation problem

Anjankumar
Novice
1,327 Views

 

I have a problem in intel MPI installation. I installed both OneAPI Basekit and HPC toolkits for MPI to work in windows 10. then i have not found mpivars.bat (batch file) even after executing env/vars.bat. I don't know that it runs properly on not. And also how to configure with visual studio? In your website, i unable to study the process if installation. Please guide me in this regard step by step. 

 

Thanks 

Anjan Kumar

 

Labels (2)
0 Kudos
1 Solution
Anjankumar
Novice
1,262 Views

Hi,

Thanks for a quick reply. Installation and programs executed are successfully.

regards

Anjan Kumar

View solution in original post

5 Replies
VarshaS_Intel
Moderator
1,288 Views

Hi,

 Thanks for reaching out to us.

  

 Below are the steps for initializing oneAPI environment in Command Prompt:

 There are multiple ways of doing it:

 Method 1: Open "Intel oneAPI command prompt for Intel 64 for Visual Studio 2019" from the Windows Search Bar.

       This will automatically initialize the Intel oneAPI Environment.You can use all the compilers(DPCPP,MPIICC etc)

     InteloneAPISearch.pngIntelDirect.png

 Method 2 : 

   Step 1: Open Windows Command Prompt 

   Step 2 : cd <install-dir> the Intel oneAPI installation directory (by default, C:\Program Files (x86)\Intel\oneAPI).

   Step 3: Launch setvars.bat which will initialize the complete oneAPI Envinornment including Intel MPI.

   InteloneAPI.png

 Method 3 :

   Alternatively if you want to initialize only Intel MPI Envinornment you can follow the below steps:

   Step 1 : Open Windows Command Prompt 

   Step 2 : cd <install-dir>\mpi\<version>.<update>\env

       (where <install-dir> is the Intel MPI Library installation directory (by default, C:\Program Files (x86)\Intel\oneAPI).

   Step 3 : Launch vars.bat which will initialize the Intel MPI Environment.

   IntelMPI.png

 In order to check whether the environment is initialized properly or not check with the below command:

     

 

mpiexec --version

 

 For more information please refer to this link:

 https://software.intel.com/content/www/us/en/develop/documentation/get-started-with-mpi-for-windows/...

  

 >>And also how to configure with visual studio?

 Could you please refer to this for the configuration

 https://software.intel.com/content/www/us/en/develop/documentation/mpi-developer-guide-windows/top/c...

 

 You can refer to this for the oneAPI with Visual Studio Integration:

 https://software.intel.com/content/www/us/en/develop/documentation/using-vs-code-with-intel-oneapi/u...

  

 If you face any issues in integrating oneAPI with Visual Studio, please post a new thread in the Registration, Download, Licensing, and Installation forum.

 Link to the forum: https://community.intel.com/t5/Registration-Download-Licensing/bd-p/registration-download-licensing-...

 

Thanks & Regards

Varsha

 

Anjankumar
Novice
1,263 Views

Hi,

Thanks for a quick reply. Installation and programs executed are successfully.

regards

Anjan Kumar

VarshaS_Intel
Moderator
1,206 Views

Hi,

 Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Thanks & Regards

Varsha


Anjankumar
Novice
1,195 Views

Thanks, after installation Intel one one API toolkit, the mpi program for Fortran and c++ executed successfully using command prompt. But, when I execute a Fortran program in visual studio 2019, it shows error, like include path, ifort.exe, mpi.h, etc. not found. I follow the same process mentioned intel site mentioned "configure a Visual Studio* project with Intel® MPI Library", not a avail

Also, from suggestions found in the community, I have also tried updating and reinstalling Visual Studio 2019. I checked that both intel64 and intel64_ia32 folder have ifort.exe present. I have also reset both architecture compilers in Tools > Options > Intel Compilers and Libraries > IFORT Intel Fortran Classic > Compilers, but unfortunately, to no avail. But in c++ programs executed successfully. In Fortran, above error was shown.

Can you share the project properties settings for Fortran? . 

Thanks and regards

Anjan Kumar

VarshaS_Intel
Moderator
1,064 Views

Hi,

Since your initial query is resolved. Could you please post any additional question in a new thread as this thread will be no longer monitored by Intel.


Also, your issue is related to setting the project properties for Fortran could you please post your question in the Intel Fortran Compiler forum.
Link to the forum: https://community.intel.com/t5/Intel-Fortran-Compiler/bd-p/fortran-compiler

 

Have a good day!

 

Thanks & Regards
Varsha

Reply