Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Pravesh_G_
Beginner
90 Views

MPI peformance snapshot

Hello team,

I am using mps(mpi performance snapshot) for analyzing. I installed intel mpi 5.0.3, itac 9.0.3 and intel compiler 15.0.3. I have already created stats.txt and app_stat.txt files but when I am using mps command for analyzing these text files, I am facing issue:

mps command not found

Please suggest me..

Regards,

Pravesh Goyal

 

0 Kudos
6 Replies
Artem_R_Intel1
Employee
90 Views

Hello Pravesh,

Please make sure that you have set all the necessary environments - see the MPI Performance Snapshot for Linux* OS User's Guide.
Pay attention that MPI Performance Snapshot tool is called 'mpi_perf_snapshot' in ITAC 9.0.3 (it has been renamed to 'mps' since ITAC 9.1). 

Pravesh_G_
Beginner
90 Views

Hello sir,

I have set all environment varraiable but same problem persist.

source /gpfs1/opt/intel/parallel_studio_xe_2015_update3/itac/9.0.3.051/bin/mpi_perf_snapshot_vars.sh

source /gpfs1/opt/intel/parallel_studio_xe_2015_update3/impi/5.0.3.048/bin64/mpivars.sh

source /gpfs1/opt/intel/parallel_studio_xe_2015_update3/composer_xe_2015.3.187/bin/compilervars.sh intel64

Please suggest me.

Regards,

Pravesh Goyal

 

Artem_R_Intel1
Employee
90 Views

Hi Pravesh,

Could you please specify the whole command which causes the mentioned error "mps command not found"? 

BTW I'd recommend to source the environment scripts in the same order as specified in the MPI Performance Snapshot for Linux* OS User's Guide.

Pravesh_G_
Beginner
90 Views

Hello,

When I am using this command

mps ./stats.txt ./app_stat.txt

-bash: mps: command not found


I have already sourced the environment scripts in the same order as specified in the MPI Performance Snapshot for Linux* OS User's Guide but same problem persist.

Regards,

Pravesh Goyal

 

 

Artem_R_Intel1
Employee
90 Views

Could you please try to run:

$ mpi_perf_snapshot ./stats.txt ./app_stat.txt

The MPI Performance Snapshot tool is called 'mpi_perf_snapshot' in ITAC 9.0.3 (it has been renamed to 'mps' in ITAC 9.1).

Pravesh_G_
Beginner
90 Views

Hello,

Problem is resolved now.

Thanks for your support.

Regards,

Pravesh Goyal

Reply