Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Stepha_France
Beginner
95 Views

Openmpi 1.10.3 and Intel parallel studio XE

Hi,

or is the error in my installation Intel parallel studio XE and of openmpi.

I install intel parallel studio XE cluster édition 16 under ubuntu 14.04 32bit

export LD_LIBRARY_ PATH= ''/opt/intel/lib ''

export DYLD_LIBRARY_ PATH= ''/opt/intel/lib ''

export MANPATH= ''/opt/intel/man''

export PATH= /opt/intel/bin:$PATH

I added in .bashrc export PATH=$PATH : /opt/intel/bin

 

can I install openmpi 1.10.3

with sudo ./configure - -prefix=/home/math/openmpi F77=/opt/intel/compilers_and_libraries_2016.3.210/linux/bin/ia32/ifort FC=/opt/intel/compilers_and_libraries_2016.3 .210/linux/bin/ia32/ifort

then sudo make all and sudo make install

export PATH=$PATH:/home/math/openmpi/bin

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/math/openmpi/bin

I also added these two lines in the file .bashrc

 

 but when compiling a program in FORTRAN I have my errors:

ld: warning: libifport.so.5, needed by /openmpi/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

ld: warning: libifcore.so.5, needed by /openmpi/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

ld: warning: libimf.so, needed by /openmpi/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

ld: warning: libsvml.so, needed by /openmpi/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

ld: warning: libifcoremt.so.5, needed by /openmpi/lib/libmpi_usempif08.so, not found (try using -rpath or -rpath-link)

 

Thanks in advance for your help

0 Kudos
1 Reply
Stepha_France
Beginner
95 Views

Hello,

the problem is solved:

export LD_LIBRARY_ PATH= ''/opt/intel/lib/ia32 ''

 

Reply