Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
2017 Discussions

Profiling of user functions using ITAC



If I try to get a traceview using "-trace" as a linking-option i get the traceview as I exspected. But in addition I want to get detailed information about the userfunctions which is the reason I started to use "-tcollect" as a parameter for compiling.

I ran the program using "mpirun -strace NAME" (details about the number of processors etc. are provided by the job-system) i got details about every function using "ungroup" - but i didn't get the TraceView (Event Timeline). In the past it worked very well, but then maybe something changed with the operating system (new version of ita, impi, compiler, kernel or something, I don't know).

I cant't use manuell instrumentation with itcpin, because of using linux with the kernel-version 3.x But instrumentation seems to work anyway, because if I'm using "tcollect" I got information about every function...

CFLAG= -tcolellct; LFLAG= -trace

I'm using the intel/12.1.13 compiler, impi/4.1.1 and itac/

 Thanks for an reply,




0 Kudos
2 Replies

Hey Bernhard,

Thanks for getting in touch.

If you're using the -tcollect compile-time option, you should be able to get access to all of your routines (MPI and non-MPI).  I'm a little unclear on what you mean by "i didn't get the TraceView (Event Timeline)".  Are you able to create and view a trace file?  I noticed that "-tcollect" is misspelled in your post below.  Just make sure you're spelling it correctly in your Makefile.

Our GUI has recently changed but all the timelines are still available for use.  Once you open the trace file with the GUI, you should see an menu option on top that says "Charts".  Once you click, you'll get a drop-down where the first option is "Event Timeline".  Are you saying you're not seeing that?

Perhaps you can also send me your trace file and I can take a look on my machine here.



Hi Gergana,

thank you for your reply! Well the problem was that the button "Event Timeline" wasn't clickable.

But I got the solution two days before (sorry about being to slow deleting my post)... it was a simple upgrade from an older version of ITAC to the current version what lead me to a new TraceView :-)

So the problem is solved and the thread can be closed.

Best regards