Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
2023 Discussions

Questions on Intel MPI and Intel Cluster MKL

I installed Intel MPI 2.0and Intel Cluster MKL and wanted to do the scalapack testing. However, when I tried to compile the scalapack tests in the cmkl directory, I have the following message:
(cd source/TESTING; make ROOTdir=/opt/intel/cmkl/8.0/tests/scalapack LIBdir= MPIdir= arch=ia32 mpi=intelmpi20 comp=intel opt=O2 dynamic= arch=ia32 dynamic=no exe run)
make[1]: Entering directory `/opt/intel/cmkl/8.0/tests/scalapack/source/TESTING'
( cd LIN ; make ROOTdir=/opt/intel/cmkl/8.0/tests/scalapack LIBdir= MPIdir= arch=ia32 mpi=intelmpi20 comp=intel opt=O2 dynamic=no comp=intel opt=O2 all )
make[2]: Entering directory `/opt/intel/cmkl/8.0/tests/scalapack/source/TESTING/LIN'
mpiifort -c -w -u -O0 psludriver.f
mpiifort -c -w -u -O0 psluinfo.f
mpiifort -c -w -u -O0 psgetrrv.f
mpiifort -c -w -u -O0 psmatgen.f
mpiifort -c -w -u -O0 pmatgeninc.f
mpiifort -c -w -u -O0 pslaschk.f
mpiifort -c -w -u -O0 pslafchk.f
mpiifort -o ../xslu_ia32_intelmpi20_intel_O2 psludriver.o psluinfo.o psgetrrv.o psmatgen.o pmatgeninc.o pslaschk.o pslafchk.o -L/opt/intel/cmkl/8.0/tests/scalapack/../../lib/32 -lmkl_scalapacktesting_intel80 -lmkl_scalapack -lmkl_blacs_intelmpi20 -lmkl_lapack -lmkl_ia32 -lguide -lpthread
IPO link: can not find "("
ifort: error: problem during multi-file optimization compilation (code 1)
make[2]: *** [../xslu_ia32_intelmpi20_intel_O2] Error 1
make[2]: Leaving directory `/opt/intel/cmkl/8.0/tests/scalapack/source/TESTING/LIN'
make[1]: *** [exe] Error 2
make[1]: Leaving directory `/opt/intel/cmkl/8.0/tests/scalapack/source/TESTING'
make: *** [lib32] Error 2
I tried MPICH2 with intel compiler, the same situation.
I successfully installed and tested MPICH2 and BLACS, SCALAPACK from netlib in the same cluster.
I'm using RH Linux, Fedora Core release 4 (Stentz)
Kernel 2.6.11-1.1369_FC4smp
0 Kudos
1 Reply


The "IPO link...problem during multi-file optimization..." message suggestsa problem with interprocedural optimization. However, I don't see the -ipo option anywhere in your option. This could also be a version mismatch but there isn't enough information to know for sure. Please submit this issue to Intel Premier Support.

Best regards,