Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Ilia_S_
Beginner
105 Views

Run and debug Intel MPI application on cluster. (Grid Engine)

Hello,
 

I have a problem in debugging of Intel MPI application on a cluster.

Common question: How to debug the parallel application. Console debugger idbc is not convenient at all. Are there debuggers with GUI? better for free.

I tried using eclipse, I launched program using SGE script (below), but I cannot debug with the same way.

The script for RUN.
############## RUN ##############
#!/bin/bash
#$ -S /bin/bash

cd $SGE_O_WORKDIR

. /etc/profile.d/modules.sh


module purge
module load 14.0_intel_mpi_update
#$ -l sandy=TRUE
#$ -l h_vmem=1.0G
#$ -o $JOB_ID.out
#$ -e $JOB_ID.err
#$ -cwd
#$ -pe openmpi* 6
#$ -l h_rt=00:30:00
#$ -l debug=TRUE

mpiexec.hydra -genv I_MPI_FABRICS shm:dapl -genv I_MPI_FALLBACK_DEVICE disable -n $NSLOTS ./myApp
exit 0
##############################

And it works. (I work in local regime, since eclipse is running on cluster frontend, ssh connection is not needed).

 
But it doesn't work in DEBUG configuration. I got error "Configuration is missing run commands for job submission dd85ff79-8053-4ffd-ade1-edb1a23272de debug"

I did like in the manual http://help.eclipse.org/luna/index.jsp?topic=%2Forg.eclipse.ptp.doc.user%2Fhtml%2F01buildMPIprog.html,  but I have some doubts, because its unclear for me what is the GDB debugger should I use. SGE script for debugging I take as follows
 
######################################
#!/bin/bash
#$ -S /bin/bash

cd $SGE_O_WORKDIR

. /etc/profile.d/modules.sh


module purge
module load 14.0_intel_mpi_update
#$ -l sandy=TRUE
#$ -l h_vmem=1.0G
#$ -o $JOB_ID.out
#$ -e $JOB_ID.err
#$ -cwd
#$ -pe openmpi* 6
#$ -l h_rt=00:30:00
#$ -l debug=TRUE

export IDB_HOME=/cluster/intel_2013SP1/bin/
export gdb_compatible_output=1

mpiexec.hydra -idb -genv I_MPI_FABRICS shm:dapl -genv I_MPI_FALLBACK_DEVICE disable -n $NSLOTS ./myApp
exit 0

######################################
 
 
Probably I don't understand something, I am newbie in MPI.
So, could anyone help me in this?
 

Regards,
Ilia Sivkov.

0 Kudos
1 Reply
Bruce_X_
Beginner
105 Views

Hello,

If I would like to use Eclipse (Mars2) to debug a MPI example (such as hello world), in configuration, which Target System Configuration" should I choose?

I am using Intel C++ and MPI, my machine is a linux box with 10 cores. 

Thanks

Reply