Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ipasichnyk
Novice
72 Views

Source location in Trace Analyzer in applications statically linked with Intel® MPI Library

Jump to solution

I want to perform analysis of the application which is compiled with the following command line:

$ mpiicc -static_mpi -trace -g myApp.c -o myApp
$ mpirun -n 4 ./myApp

Additionally I record the location of my function calls by setting the environment variable VT_PCTRACE with the following command

$ export VT_PCTRACE=5

By opening an stf file in the Trace Analyzer GUI the dialog "Details on Funciton MPI" contains link "Show source". But on clicking this link appears the window "None of the source files are available" (see attachments). I perform all actions (compiling, collecting and analyzing) from the same directory.

Interesting that by dynamically linking MPI library everything works fine.

My version of itac is 9.0.3.049.

 

 

0 Kudos
1 Solution
Artem_R_Intel1
Employee
72 Views

Colleagues have prompted more elegant solution for this - use 'mpiicc -nostrip ...':

-nostrip
Use this option to turn off the debug information stripping while linking the Intel® MPI Library statically.

View solution in original post

3 Replies
Artem_R_Intel1
Employee
72 Views

Hi Igor,

Could you please submit a ticket for this problem via Intel Premier Support?

Artem_R_Intel1
Employee
72 Views

Hi Igor,

If you prefer to use static MPI libraries you can try the following W/A:

Run 'mpiicc -static_mpi -trace -g myApp.c -o myApp -show' - there should be output like this:
icc ...
objcopy ...
objcopy ...
objcopy ...

Compile your MPI application with the shown icc command line (without objcopy). Check that source code is visible in the Intel Trace Analyzer.

Artem_R_Intel1
Employee
73 Views

Colleagues have prompted more elegant solution for this - use 'mpiicc -nostrip ...':

-nostrip
Use this option to turn off the debug information stripping while linking the Intel® MPI Library statically.

View solution in original post

Reply