Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kutovoi__Vadim
Beginner
56 Views

Troubles with Intel MPI library

Hello, im student and have just started to learn HPC using Intel MPI lib. I created two virtual machines wich using CentOs. First of all i ran this code   "mpirun -n 2 -ppn 1 ip1, ip2 hostname" and it worked well and when I tried to run test program on one node it worked. But when i tried to run test program from Intel MPI tests i got this error. Also i used MPICH, but without such troubles.

0 Kudos
1 Reply
Dmitry_G_Intel
Employee
56 Views

Hi Vadim,

If you use traditional Ethernet as a network (i.e. TCP/IP communications, the issue can be observed when several IP interfaces are configured on you machines, but some of them can't be used for internode communications between two computational nodes.

Please, ensure that OFI/sockets provider uses the correct IP interface by specifying FI_SOCKETS_IFACE="ip_iface_name" environment variable. For example, you have something like 3 IP interfaces: lo, eth0 (can't be used for internode communications), eth1 - OFI/sockets provider will use eth0 by default in this case. When you specify FI_SOCKETS_IFACE=eht1, this issue should go away.