Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1917 Discussions

Warning when sourcing the pcsevars.sh file

Paul_I_1
Beginner
288 Views

I get a warning when I source the file ...source /opt/intel/16.0/parallel_studio_xe_2016.0.047/psxevars.sh intel64

mpsvars.sh: Warning: Hardware events collection is disabled by default. To enable it, run mpsvars.sh with --vtune (recommended) or --papi option.

Why is this a warning?

0 Kudos
6 Replies
James_T_Intel
Moderator
288 Views

This is related to the MPI Performance Snapshot tool.  The warning is to alert users that by default, there is no hardware event collection enabled in MPS, and you must explicitly enable it.

I'm going to move this to the correct forum.

Paul_I_1
Beginner
288 Views

The right way to do this is something like

/opt/intel/16.0/parallel_studio_xe_2016.0.047/psxevars.sh intel64 mps_hardware_events={yes|no}

Running the mpsvars.sh twice is not ideal.

 

James_T_Intel
Moderator
288 Views

I've put in a feature request to pass MPS options through to mpsvars.sh.

Andrew_R_2
Beginner
288 Views

Hello,

I am running Ubuntu 16.04 LTS and I receive the following warning when I start the terminal:

mpsvars.sh: Warning: Hardware events collection is disabled by default. To enable it, run mpsvars.sh with --vtune (recommended) or --papi option.

What command should I run to correct this?

Thanks,

Andrew

James_T_Intel
Moderator
288 Views

As the warning message states, using mpsvars.sh --vtune or mpsvars.sh --papi.

James_T_Intel
Moderator
288 Views

The developers will not be implementing this.  In order to pass specific, non-default arguments to mpsvars.sh, you will need to call it directly.

Reply