Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Estanislao_G_
Beginner
477 Views

cannot open source file "mpi.h"

 

Dear all

I am trying to run this make file,  but I am having this error "catastrophic error: cannot open source file "mpi.h"
  #include <mpi.h>. I am sure I have a problem with the make file, but knowledge in linux is low. Thanks in advance for your help

export HDF5_INC_DIR=$/usr/local/hdf5/include

export HDF5_LIB_DIR=$/usr/local/hdf5/lib

export NETCDF_INC_DIR=$/usr/local/netcdf4/include

export NETCDF_LIB_DIR=$/usr/local/netcdf4/lib /usr/local/netcdf4-fortran/lib

export $MPI_INC_DIR=$/opt/intel/impi/5.1.1.109/bin64

NETCDF_INCDIR="-I $NETCDF_INC_DIR"

NETCDF_LIBDIR="-L $NETCDF_LIB_DIR"

NETCDF_LIB="-lnetcdff -lnetcdf"

MPI_INCDIR="-I $MPI_INC_DIR"

MPI_LIBDIR=""

MPI_LIB=""

HDF5_INCDIR="-I $HDF5_INC_DIR"

HDF5_LIBDIR="-L $HDF5_LIB_DIR"

HDF5_LIB="-lhdf5_hl -lhdf5 -lhdf5 -lz"

################################################################################

################### Projet xios - xmlioserver #####################

################################################################################

 

%CCOMPILER /opt/intel/bin/icc

%FCOMPILER /opt/intel/bin/ifort

%LINKER /opt/intel/bin/ifort

%BASE_CFLAGS -ansi -w

%PROD_CFLAGS -O3 -DBOOST_DISABLE_ASSERTS

%DEV_CFLAGS -g -O2

%DEBUG_CFLAGS -g

%BASE_FFLAGS -D__NONE__

%PROD_FFLAGS -O3

%DEV_FFLAGS -g -O2

%DEBUG_FFLAGS -g

%BASE_INC -D__NONE__

%BASE_LD -lstdc++

%CPP opt/intel/bin/icc -EP

%FPP cpp -P

%MAKE make

Kind regards,

Estanislao

 

0 Kudos
5 Replies
Artem_R_Intel1
Employee
477 Views

Hello Estanislao,

You should pass <impi_install_dir>/intel64/include with '-I' compiler option and <impi_install_dir>/intel64/lib with '-L' compiler option. Alternatively you can use MPI compiler wrappers scripts from <impi_install_dir>/intel64/bin.

Estanislao_G_
Beginner
477 Views

Hi Artem,

I am using  Intel® Parallel Studio XE 2016. If I go to the impi folder there is not a include folder(opt/intel/impi/5.1.1.109/intel64/). I might be in the wrong folder. Thanks so much for your help, it is quite difficult to set these things with my level.

Artem_R_Intel1
Employee
477 Views

Hi Estanislao,

If intel64/include folder is missing it's possible that there's only Intel MPI Library runtime environment installed. You need to install full Intel MPI Library package (it's a separate component of the Intel® Parallel Studio XE 2016).

Estanislao_G_
Beginner
477 Views

Hi Artem,

I suspected I needed to install something else. Do you know where I can find that package? I thought I was inside the cluster Studie XE 2016 because there was a section to install MPI libraries.Thanks for your help

Estanislao

Artem_R_Intel1
Employee
477 Views

Hi Estanislao,

Please make sure you use Intel® Parallel Studio XE 2016 Cluster Edition and the appropriate license. There should be Intel MPI Library component which can be installed with standard installation program.

Reply