Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ab1
Beginner
307 Views

error #7002: Error in opening the compiled module file. Check INCLUDE paths

hi

I am compiling a source code not developed by me but is available freely.  Hence I am not expert in the internal functioning and intricacies. Being an end user, my purpose is to compile and run.

My ubuntu is 18.04, ifort  19.0.4.243   and codes use parallel support/ mpi, 64 byte interface.

my compilation using mpiifort leads to following errors

/source/mpi-ci-diag/Modules/Dispatcher/Dispatcher_module.F90(57): error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [SLEPCMATRIX_MODULE]
    use SLEPCMatrix_module,               only: SLEPCMatrix, initialize_slepc
--------^
/source/mpi-ci-diag/Modules/Dispatcher/Dispatcher_module.F90(58): error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [SLEPCDIAGONALIZER_MODULE]
    use SLEPCDiagonalizer_module,         only: SLEPCDiagonalizer
--------^
/source/mpi-ci-diag/Modules/Dispatcher/Dispatcher_module.F90(62): error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [SCALAPACKMATRIX_MODULE]
    use SCALAPACKMatrix_module,           only: SCALAPACKMatrix
--------^

source/mpi-ci-diag/Modules/Dispatcher/Dispatcher_module.F90(57): error #6580: Name in only-list does not exist or is not accessible.   [SLEPCMATRIX]
    use SLEPCMatrix_module,               only: SLEPCMatrix, initialize_slepc

..

...

..

compilation aborted for /source/mpi-ci-diag/Modules/Dispatcher/Dispatcher_module.F90 (code 1)
source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/build.make:158: recipe for target 'source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/Modules/Dispatcher/Dispatcher_module.F90.o' failed
make[3]: *** [source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/Modules/Dispatcher/Dispatcher_module.F90.o] Error 1
source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/build.make:174: recipe for target 'source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/Modules/Dispatcher/Dispatcher_module.F90.o.provides' failed
make[2]: *** [source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/Modules/Dispatcher/Dispatcher_module.F90.o.provides] Error 2
CMakeFiles/Makefile2:1119: recipe for target 'source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/all' failed
make[1]: *** [source/mpi-ci-diag/CMakeFiles/mpi-scatci.dir/all] Error 2
Makefile:140: recipe for target 'all' failed
make: *** [all] Error 2

 

i found out Dispatcher_module.F90.o is not created. however many other .o files are created in different folders. what is the source of this error ? is it that i am missing some paths/ include statements/libraries in environment settings ? in my bashrc file , i have mentioned following settings.

 source /opt/intel/compilers_and_libraries_2019.4.243/linux/mpi/intel64/bin/mpivars.sh
   source /opt/intel/compilers_and_libraries_2019/linux/bin/compilervars.sh intel64
 
  source /opt/intel/parallel_studio_xe_2019.4.070/compilers_and_libraries_2019/linux/bin/ifortvars.sh intel64
    source /opt/intel/compilers_and_libraries_2019.4.243/linux/mkl/bin/mklvars.sh intel64 ilp64 mod

i have not linked any mpi libraries/ include commands. whereas i am using miifort in compilation

any help will be highly appreciated. pl don't mind I am not an expert in this field.

thank you

ab

 

0 Kudos
6 Replies
PrasanthD_intel
Moderator
307 Views

 

Hi ,

  • This error occurs when the module file you are using in a code is not pre-compiled or is unavailable when running the code.
  • The message "Error in opening the compiled module file" means that the compiler can not locate the .mod file. For example , the Foo.mod file is expected when compiler encounter "USE Foo" in a source file.
  • Add the *.mod file to the appropriate include path if you found the module path

          or

         check if you have the source file for the  SLEPCMATRIX_MODULE and  compile it along with the Dispatcher_module.f90 file.

Please let me the know if you any further queries.

Thanks

Prasanth

PrasanthD_intel
Moderator
307 Views

Hi,

Have you tried with the given steps, is the error resolved?

If not please let us know the status.

 

Thanks 

Prasanth

ab1
Beginner
307 Views

Mr Prashant

In continuation to above post, i explored a bit further . I require arpack, PETSc and SLEPc files the commands to be used for compiling as given in mannual are

ulimit -s unlimited

~/Desktop/JUNK/ukrmol-in-3.0-march-16/build$ cmake -D CMAKE_C_COMPILER=$(which icc) \

-D CMAKE_Fortran_FLAGS="-mkl=cluster -i8" \

 is coming from mkl=cluster ..... if i use only mkl, the codes are compiled

If i use mkl=cluster i get the above message

i am unable to understand the root cause.

can you pl enlighten me more on issue

 

ab

PrasanthD_intel
Moderator
307 Views

Hi

The  CMAKE_Fortran_FLAGS is being used as an input to the Fortran compiler and the Intel Fortran compiler links MKL libraries when you give -mkl flag.

You can give 3 types of arguments to the -mkl flag as per your requirements. The cluster argument tells the compiler to link cluster-specific libraries and the sequential libraries in the Intel® MKL

Check below link for more info

https://software.intel.com/en-us/fortran-compiler-developer-guide-and-reference-mkl-qmkl

Could you please mention the error you are getting while running with mkl=cluster?

If the error looks something like this :

ld: cannot find -lmkl_<cdft_core>

You can group the libraries and include them while running the code as mention in the below link:

https://software.intel.com/en-us/mkl-linux-developer-guide-linking-with-intel-mkl-cluster-software

Hope this information helps. Get back to us if you need any help.

Also if your initial query is resolved please raise a new thread for further questions.

 

Thanks

Prasanth

 

 

PrasanthD_intel
Moderator
307 Views

Hi,

Have you tried with the given steps, is the error resolved?

If not please let us know the details.

 

Thanks 

Prasanth

PrasanthD_intel
Moderator
307 Views

Hi,

We are closing this assuming your problem is resolved.

Please raise a new thread if you face any further issues.

 

Thanks

Prasanth

Reply