Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Krishna_P_1
Beginner
561 Views

error while loading shared libraries: libiomp5.so: cannot open shared object file: No such file or directory

Jump to solution
I wrote a MPI Program to run on Intel Xeon Phi in native mode. I am using Stampede super computer. I have defined omp pragmas in the code. I have compiled using following command $mpiicc program.c -openmp -mmic To submit as a batch file, script file has the following commands #!/bin/bash #SBATCH -J myMPI # job name #SBATCH -o result.o%j # output and error file name (%j expands to jobID) #SBATCH -e result.e%j #SBATCH -N 1 -n 2 # total number of mpi tasks requested #SBATCH -p normal-mic # queue (partition) -- normal, development, etc. #SBATCH -t 00:10:00 # run time (hh:mm:ss) - 1.5 hours scp a.out mic0:/tmp export I_MPI_MIC=enable ibrun -host mic0 /tmp/a.out # run the MPI executable named a.out I am getting the following errors /tmp/a.out: error while loading shared libraries: libiomp5.so: cannot open shared object file: No such file or directory /tmp/a.out: error while loading shared libraries: libiomp5.so: cannot open shared object file: No such file or directory somebody please help me how to get rid of these errors.
0 Kudos
1 Solution
TimP
Black Belt
561 Views

One would think the procedure for using compiler shared libraries would be covered in stampede FAQ. If you don't have available a module command and don't have privilege to upload .so to the default path you must set ld_library_path to match where you upload it.

View solution in original post

2 Replies
Artem_R_Intel1
Employee
561 Views

Hi Krishna,

Your MPI application depends on libiomp5.so, so you should ensure that this library is available on the Xeon Phi and dynamic linker is able to find it.

TimP
Black Belt
562 Views

One would think the procedure for using compiler shared libraries would be covered in stampede FAQ. If you don't have available a module command and don't have privilege to upload .so to the default path you must set ld_library_path to match where you upload it.

View solution in original post

Reply