Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
28 Views

hfi1 driver version confusion

I previously installed IntelOPA-IFS.RHEL72-x86_64.10.1.1.0.9 to set up an Omni-Path cluster. I noticed that this version of the Omni-Path software includes hfi1-0.11.3.10.0_327.el7.x86_64-248.src.rpm and after installing, hfi1 version 0.11-162 was present on the system.

I recently upgraded to IntelOPA-IFS.RHEL72-x86_64.10.2.0.0.158 and noticed that this version does not include an hfi1 driver. After upgrading, the system loads hfi1 version 0.9-294, which is the version included with the kernel.

What is the latest version of the hfi1 driver? From the version numbers I'd guess 0.11-162 is newer than 0.9-294. If that's the case then why does upgrading to the latest Omni-Path software result in reversion to an older driver version? Additionally it looks like a version of the hfi1 driver source code is also present here: https://github.com/01org/opa-hfi1, however the commit comments indicate that the latest version is 0.11-156 but the actual version string in common.h is 0.11-162, leading to more confusion.

Is there a reason not to use driver version 0.11-162 with the latest Omni-Path software? Assumably it would be better to use the latest version.

Thanks

0 Kudos
0 Replies