Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Chaowen_G_
Beginner
64 Views

how to install intel mpi from parallel studio xe 2016 cluster version linux

Hi:

I have intel parallel studio xe 2016 cluster version linux. But I can not install all the cluster related tools from it. There is no option to choose cluster tools, I download the whole install package into my computer and then install it. I just see:

2. [ ] Intel(R) MPI Library 5.1 Update 1 (already installed)
3. [ ] Intel(R) VTune(TM) Amplifier XE 2016 (already installed)
4. [ ] Intel(R) Inspector XE 2016
5. [ ] Intel(R) Advisor XE 2016
6. [ ] Intel(R) C++ Compiler 16.0
7. [ ] Intel(R) Fortran Compiler 16.0
8. [ ] Intel(R) Math Kernel Library 11.3
9. [ ] Intel(R) Integrated Performance Primitives 9.0
10. [ ] Intel(R) Threading Building Blocks 4.4
11. [ ] Intel(R) Data Analytics Acceleration Library 2016
12. [ ] Intel(R) Debugger for Heterogeneous Compute 2016
13. [ ] GNU* GDB 7.8

then I go into 2 and see

Intel(R) MPI Library 5.1 Update 1
       Intel(R) MPI Library, Runtime Environment for applications running on
Intel(R) 64 Architecture (required)
       Intel(R) MPI Library, Runtime Environment for applications running on
Intel(R) Many Integrated Core Architecture (required)


there is no mpi benchmark and mpi sdk tools

all the tools are just like professional version, not cluster version. I have to download intel mpi and Intel Trace Analyzer and Collector packages and install them separately. It is quite convenient. Is there any way to install everything at the same time?

My computer linux mint 17.2.

 

0 Kudos
5 Replies
Artem_R_Intel1
Employee
64 Views

Hi Chaowen,

Which license do you use?

Chaowen_G_
Beginner
64 Views

I use a student license
 

Artem_R_Intel1
Employee
64 Views

Hi Chaowen,

Could you please provide the scenario how you have activated this installation?

Gergana_S_Intel
Employee
64 Views

Hi Chaowen,

According to the install dialog you provide in your post, the installer seems to think that Vtune and the Intel MPI Library are already installed on the system and it won't install them again.

Furthermore, make sure you're using the right license during your installation.  I looked up your email address and you seem to have a license for both the Cluster Edition and the Professional Edition.  Are they in the same directory, by any chance?  I wonder if the installer is picking up the license for the Professional Edition first and that's why you're seeing these prompts.

Let's try uninstalling everything first so we have a clean slate.  Then reinstall but now set INTEL_LICENSE_FILE=/path/to/cluster/edition/license/file.lic prior to running the install.sh script.  This should pick up the correct license.  If your license for the Professional Edition is in the same location, try renaming it or moving it out.

Let us know how that goes.

Regards,
~Gergana

Chaowen_G_
Beginner
64 Views

Thank you, problem solved

Reply