Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
1829 Discussions

installing intel-fortran compiler on centos 6.9 OS

sanaboyana
Beginner
560 Views

Hello, 

I was trying to install intel-fortran compiler using the latest intel oneAPI HPCkit on centos 6.9 operating system. However, during installation the terminal freezes by suggesting intel's version is not compatible/tested on the old centos 6.9 (warning is attached). Could you direct me to the version that supports my OS (centos 6.9). 

I am an academic user/student at the university of Iowa.

Thanks

Venkata Sanaboyana

Grad student, University of Iowa

0 Kudos
5 Replies
PrasanthD_intel
Moderator
542 Views

Hi Venkat,


You can find the Supported Operating systems for OneAPI HPC toolkit in its release notes (Intel® oneAPI HPC Toolkit System Requirements).

Currently CentOS* 7.x, 8.x are the supported CentOS versions.

Also, we recommend installing the OneAPI Base Toolkit before installing HPC Kit.


Regards

Prasanth


sanaboyana
Beginner
531 Views

Hello Prasanth, 

Thank you very much for a quick response. 

I unfortunately may not be able to upgrade to latest OS from centos6.9 in our cluster. So, I am trying to find a work around to renew/find a licence for an already installed Fotran compiler (2016 version) in our centos 6.9 OS. The academic license to the preinstalled compiler was recently expired (Dec 18), until then the compiler was working well. So, could you please direct me to a site where I can get the academic/student licence for the Fortran compiler (2016 version) in our cluster.    

Here are the additional details which might be helpful.

When I enter ifort on my terminal.

####

ifort

Error: Product support for your (Comp-FL) license has expired.
License file(s) used were (in this order):
1. Trusted Storage
** 2. /opt/intel/compilers_and_libraries_2016.2.181/linux/bin/intel64/../../Licenses
** 3. /root/Licenses
** 4. /opt/intel/licenses/l_BS7F9MX2.lic
** 5. /opt/intel/licenses/l_JBDJMKCF.lic
** 6. /opt/intel/licenses/l_SL6BLP3D.lic
** 7. /opt/intel/licenses/l_VXZTMLF6.lic
** 8. /Users/Shared/Library/Application Support/Intel/Licenses
** 9. /opt/intel/compilers_and_libraries_2016.2.181/linux/bin/intel64/*.lic

Please refer https://software.intel.com/en-us/faq/purchasing-renewing-upgrading#support-expiration for more information..

ifort: error #10052: could not checkout FLEXlm license

####

Thank you in advance for any help you may provide. 

Venkat 

PrasanthD_intel
Moderator
509 Views

Hi Venkat,


The Fortran 2016 is no longer supported. For a list of supported versions please refer to Intel® Parallel Studio XE Supported and Unsupported Product Versions.


We do not deal with licensing issue in forums, could you please raise a ticket on an online service center they would be able to provide you immediate support on this issue. You can reach the online service center at the below URL.

Online Service Center (intel.com) or Priority Support (intel.com)


Let us know if you have any other queries other than licensing.


Regards

Prasanth


PrasanthD_intel
Moderator
484 Views

Hi Venkat,


We haven't heard back from you. If you have any other issues other than licensing, please let us know.

If you don't have any, please confirm so we close the thread.


Regards

Prasanth


PrasanthD_intel
Moderator
416 Views

Hi Venkat,


We are closing this thread assuming your issue has been resolved. We will no longer respond to this thread. If you require additional assistance from Intel, please start a new thread. Any further interaction in this thread will be considered community only


Regards

Prasanth


Reply