Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
5 Views

mpi on Vista 64 mapped drive

Jump to solution
Running on a shared memory machine, and in a current directory j:\myprog - where J: is mapped tp c:\users\john\documents, I discovered that all the mpi instances report the current directory as c:\windows\system32. After some hair loss, I tried switching to the canonical directory - c:\users\john\documents\myprog - and it works. It also works if I use -wdir to specify the canonical directory, but not if I use the mapped drive with -wdir.

Is this a bug?
0 Kudos

Accepted Solutions
Highlighted
5 Views
Hi johnappleyard377,

I would suggest using the -mapall version for the Intel MPI Library for Windows*. This should create the user-mapping of the C:usersjohndocuments on all nodes of the cluster. There are no arguments for this option, simply add "-mapall" to your mpiexec command line:

mpiexec -mapall j:myprog

More info is available in the Intel MPI Library Reference Manual available in the docfolder.

Regards,
~Gergana

===================================
Gergana Slavova
Technical Consulting Engineer
Intel Cluster Tools
E-mail: gergana.s.slavova@intel.com
gss

View solution in original post

0 Kudos
1 Reply
Highlighted
6 Views
Hi johnappleyard377,

I would suggest using the -mapall version for the Intel MPI Library for Windows*. This should create the user-mapping of the C:usersjohndocuments on all nodes of the cluster. There are no arguments for this option, simply add "-mapall" to your mpiexec command line:

mpiexec -mapall j:myprog

More info is available in the Intel MPI Library Reference Manual available in the docfolder.

Regards,
~Gergana

===================================
Gergana Slavova
Technical Consulting Engineer
Intel Cluster Tools
E-mail: gergana.s.slavova@intel.com
gss

View solution in original post

0 Kudos