Community
cancel
Showing results for 
Search instead for 
Did you mean: 
David_M_17
Beginner
78 Views

settings for xeon phi mpi

OK one of my settings is wrong.  I can not figure out which one it is.  When I enter:  "mpirun -hosts mic0 -np 128 ./a.out"  I get an error /packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/intel64/bin/pmi_proxy:  No such file or directory. 

I have the following settings on the host:  

env | grep MPI
I_MPI_ROOT=/usr/local/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi

echo $I_MPI_MIC enable env | grep -i mpi MANPATH=/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/man:/packages/intel/16/linux/man/en_US:/usr/share/man LD_LIBRARY_PATH=/usr/local/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/mic/lib:./:/usr/local/packages/intel/16/linux/mkl/lib/intel64:/usr/local/packages/intel/16/linux/compiler/lib/intel64:/usr/local/packages/intel/16/linux/mpirt/lib/intel64:/usr/local/packages/intel/16/linux/ipp/lib/intel64:/usr/local/packages/intel/16/linux/tbb/lib/intel64:/usr/local/packages/intel/impi/5.1/intel64/lib PATH=/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/intel64/bin:/packages/intel/16/linux/bin/intel64:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/users/dmackay/bin LOADEDMODULES=mpi/intel-5.1:intel/16 If I ssh onto the mic card: ssh mic0 dmackay@system-mic0:~$ ls /usr/local/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/ or ls /usr/local/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi/mic/bin IMB-MPI1 hydra_nameserver mpiexec mpifc mpiicpc mpivars.sh IMB-NBC mpicc mpiexec.hydra mpigcc mpiifort pmi_proxy IMB-RMA mpicleanup mpif77 mpigxx mpirun tune cpuinfo mpicxx mpif90 mpiicc mpivars.csh ssh mic0 I_MPI_ROOT=/usr/local/packages/intel/compilers_and_libraries_2016.3.210/linux/mpi So why is the MIC card looking in the intel64 bin? What env setting do I have wrong?

 

 

 

 

 

 

0 Kudos
2 Replies
Artem_R_Intel1
Employee
78 Views

Hi David,

Could you please specify the exact reproducer (with all Intel MPI environment variables you set)?

David_M_17
Beginner
78 Views

Thank you Artem,

Difficulty cutting and pasting into these forum editing boxes (but you saw that I had problem editing in the first box submission).   I have things working now.   My environment settings were wrong.   Notice in my original posting when I entered echo $I_MPI_MIC I got the correct result - "enable"   but also notice that when I entered "env | grep -i mpi" I_MPI_MIC was not part of the environment settings!   My script setting this was configured wrong.   When I corrected the script setting my environment and then enter "env | grep -i mpi" I_MP_MIC is part of the environment settings (and other things).     Things are working correctly for me now thank you.


 


 

 

 

 

 

Reply