Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kims_W
Beginner
127 Views

sshconnectivity

 

hello,

I connected coprocessor like

       # ssh mic0

it didn't need a password before.

but after I run this command below ssh asked password.

         # ./sshconnectivity.exp machines.LINUX

 

What should I do for recovery like before.

I just run sshconnectivity.exp

Please help,

0 Kudos
3 Replies
Kims_W
Beginner
127 Views

This is the messages..

 

(host)#./sshconnectivity.exp machines.LINUX


Enter your user password:
Re-enter your user password:
spawn /bin/sh
ssh-keygen -t rsa
sh-4.1# ssh-keygen -t rsa
Generating public/private rsa key pair.
Enter file in which to save the key (/root/.ssh/id_rsa):
/root/.ssh/id_rsa already exists.
Overwrite (y/n)? y
Enter passphrase (empty for no passphrase):
Enter same passphrase again:
Your identification has been saved in /root/.ssh/id_rsa.
Your public key has been saved in /root/.ssh/id_rsa.pub.
The key fingerprint is:
cf:9d:28:f4:5c:af:15:fa:50:96:89:eb:b3:a8:76:3d root@localhost.localdomain
The key's randomart image is:
+--[ RSA 2048]----+
|                 |
|                 |
|                 |
|             . o |
|        S   o *  |
|       . = + B . |
|        . *.* o  |
|        ...oE=   |
|       ..o. ++.  |
+-----------------+
sh-4.1# cat ~/.ssh/*.pub >> ~/.ssh/authorized_keys
sh-4.1# chmod go-rwx ~/.ssh/authorized_keys
sh-4.1# cat ~/.ssh/*.pub >> ~/.ssh/authorized_keys.exp8.root
sh-4.1# chmod go-w ~/../root
sh-4.1# ssh localhost
Last login: Fri Jan 17 17:18:22 2014 from localhost
[root@localhost ~]# ssh -n mic0 ls -aC ~/.ssh
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied (publickey,password,keyboard-interactive).
[root@localhost ~]#
[root@localhost ~]# scp ~/.ssh/authorized_keys.exp8.root mic0:~/.ssh/authorized_keys.exp8
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied (publickey,password,keyboard-interactive).
lost connection
[root@localhost ~]#
[root@localhost ~]# ssh -n mic0 grep -f ~/.ssh/authorized_keys.exp8 ~/.ssh/authorized_keys
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied, please try again.
root@mic0's password:
Permission denied (publickey,password,keyboard-interactive).
[root@localhost ~]#
[root@localhost ~]# ssh -n mic0 chmod go-rwx ~/.ssh/authorized_keys
root@mic0's password:

Kims_W
Beginner
127 Views

.

TimP
Black Belt
127 Views

In my experience, sshconnectivity has to be run immediately after service mpss start  (or restart, prior to any other MIC access), When you have working settings, follow by service mpss stop and micctrl --resetdefaults to make them permanent.

Reply