Showing results for 
Search instead for 
Did you mean: 

wmpiconfig on 64-bit Win 7


I ran wmpiregister on my workstation (Win 7 Pro x64, Composer XE 2011 Update 2) but when I tried the wmpiconfig tool (both the 32-bit and the 64-bit versions), I get timeouts whenever I click browse to select hosts. This is followed by a unkown error code 3, similar to what is disccused here:

I get a similar problem if I define localhost or directly in my list of hosts and try to look at the properties: a long timeout followed by a message about being unable to connect and eventually, a message indicating the program has to close.

Since MPICH2 is used as a basis for Intel MPI, can I assume that this is the same problem I am seeing here ?

Note that I also tried a different machine running Vista x64 with the latest runtime and saw the same symptoms.
0 Kudos
4 Replies

Sorry, should have said error 53, not 3. Attached is a screenshot of the error (Add Hosts window -> Browse).

A related question: does the user in wmpiregister have to be a network-level login ? We do not have an AD domain in the office and since we have not yet built a cluster, we were planning to use a few different workstations, all of which would have an account with the same name/password.

Hi Michel,

You can try using of 'mpiexec register' instead of the wmpiregister GUI utility to register your credentials. Probably you'll get a bit more information.
At least any user must be known on all nodes.



Hi Dmitry,

Actually, it was wmpiconfig I had trouble with, not wmpiregister. But I tried your suggestion and this brought another question:

C:\Users\lestrade>mpiexec -register
account (domain\user) [lestrade-PC\lestrade]:

(works, give me the same message as wmpiregister about encrypting my password into the registry)

Since all my machines are in a workgroup and not a domain (we are a small shop), does this mean that even if I use the same user name & password for the local accounts on all my nodes, it will not be considered the same "user" for the purposes of launching processes with MPI ?

From the input prompt, it seems like it uses the local PC name instead of the domain but I do not know it matters here. For example, SMB shares work fine even with local user accounts when the name and password match. Does MPI care about this ?

Hi Michel,

I think, as far as MPI is concerned you need the same username and password across all the machines you want mpiexec to use (at least, that's the simplest approach in a Workgroup environment) - and they must be registered. This is different to other (especially disk) networking options that exist within the O/S environment.

BTW, the username that is registered is just to validate that you are an authorised user. The actual job runs in the SYSTEM space - which is why you need to specify paths to where you want the job to run - even if they are in the user's area.

Cheers, Geoff