Intel® oneAPI IoT Toolkit
Get answers to your questions about bringing big data technology and IoT to healthcare, smart homes, aerospace, security, and more.
22 Discussions

Running the new Intel emulator for Android


Lately, Google and Intel have published a new way to run the emulator, which should work much better than the previous version (which has emulated ARM CPU). Here are some links about it: this

However, after installing the new components and creating a new emulator configuration as instructed, I get an error and I also can't see any improvements. I've tried both API 10 and API 15, and with GPU enabled and disabled. None of those configurations helped. I've also tried it on two different computers and didn't get any boost (and got the same errors).

It seems that on the posts I've read about it, nobody had any problems with it, and all report a much faster emulator.


The error it shows is:



emulator: Failed to open the HAX device!
HAX is not working and emulator runs in emulation mode
emulator: Open HAX device failed



Why is it happening, and is there a way to fix it? Is there anyone else who gets those errors or vice versa?

By the way, I have an Intel CPU, if that could be a problem. Although I also get some references from this article react native.





0 Kudos
0 Replies